This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 27956 - Disk Druid reports wrong disk size, negative free space
Disk Druid reports wrong disk size, negative free space
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 54305 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-16 03:45 EST by Tom Hildebrand
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 19:00:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Hildebrand 2001-02-16 03:45:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win98; U)


During a Fisher install, Disk Druid misreports the capacity of a Maxtor 40GB disk as only approx. 7 GB. It wouldn't let me create my desired 
38GB partition.  Since this was a showstopper for my installation, I removed the disk and partitioned it in another machine using cfdisk (no 
problems here, cfdisk properly identified my disk as having 16 cylinders, 63 sectors per track, 79406 cylinders and 40,981,118,976 Bytes.)  
After moving the partitioned disk back and rerunning the Fisher install, disk druid reports 16 heads, 63 sectors per track, 13,870 cylinders 
(wrong!) and 6,826 MB (wrong!). My partition shows up correctly as 38,391MB, but as a result of the earlier miscalculation druid reports the 
remaining free space as  -31,565MB (negative, very wrong!).  In spite of this I skipped partitioning in disk druid, and continued the installation 
which finished without any further problems.

Reproducible: Always
Steps to Reproduce:
1.Use disk druid to partition a Maxstore 40 GB disk
2.
3.
	

Actual Results:  Disk Druid reports the disk size as 13,870 Cylinders (6,826 MB)

Expected Results:  79406 Cylinders (40,981,118,976 Bytes), as reported by cfdisk (this number appears credible)

I have several Maxtor 40GB (7200 rpm) disks. Although the retail box looks the same and the available disk space is always 40,981,118,976 
Bytes (40GB, as advertised), some disks are 79,406 cyl / 16 heads / 63 sec per track while others are 4,982 cylinders / 255 heads / 63 sec 
per 
track. Only the former create the disk druid problem described above, the latter don't.
Comment 1 Michael Fulbright 2001-02-16 10:05:07 EST
Fixed in CVS.
Comment 2 Brent Fox 2001-10-15 12:23:35 EDT
*** Bug 54305 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.