Bug 27966 - RFE: Increase Component combo box vertical height
RFE: Increase Component combo box vertical height
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-16 11:00 EST by Mike A. Harris
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-05 00:22:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2001-02-16 11:00:12 EST
Problem:
When viewing a bug report in bugzilla, if you need to change the
component of a misfiled bug for example, you will need to scroll down
the mile long list of package names in the Component combo box.

Unfortunately, the scroll bar is next to useless because moving it one
pixel makes it scroll up or down a large amount making it difficult to
control.  Also there are only about 10 packages listed in this list that
are visible at any one time.

Solution:
There is ample vertical space underneath the combo box that is not
currently used for anything at all, and if the combo box vertical
size were increased to triple it's current size, 3 times
as many packages could be displayed on the screen at once making
package selection much simpler, and making the scroll bar much more
effective.  Bugzilla users everywhere would rejoice and get severe
goose pimples (the good kind, not the kind you get when someone scrapes
their fingernails down a blackboard) the next time they needed to change
a component in a bug report.  This could have a cascading effect of
goodwill in the noosphere.
Comment 1 David Lawrence 2001-02-16 12:25:39 EST
Ok, I upped the component list box size to 11 from 7. Anymore and it starts to
stretch my table so I
would have add extra blank rows which I would rather not :) See if this makes it
a little better for you. I also upped the list box size for the
product/version/component stuff on the query page as well since after thinking
about it, 5 was really small for those too.
Comment 2 Mike A. Harris 2001-02-16 19:15:25 EST
That is a slight bit better but not too noticeable...  Could the main
table be restructured so the right side is on it's own?  Like this:


+-------------------------------------------------------------------+
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
|                     |                       |                     |
+---------------------------------------------+                     +
|                                             |                     |
|                                             |                     |
|                                             |                     |
|                                             |                     |
|                                             |                     |
|                                             |                     |
|                                             |                     |
|                                             |                     |
|                                             |                     |
|                                             |                     |
|                                             |                     |
+-------------------------------------------------------------------+

Not sure how big a job that would be.. It'd be nice to have that combo use all
the area there though.  Attaching a screenshot so you can see what I see in
case we're set up differently..
Comment 3 David Lawrence 2001-02-16 21:25:42 EST
Hmm, that diagram shows up correctly in the email notice that was sent to me but
is wierd when the browser gets a hold of it. I will look into doing this
tomorrow. All the tables stuff is laid out in an HTML template so it is easy to
move around. I would have to shrink down the text fields (whiteboards, summary,
etc.) a little bit so that the page width stayed the same.
Comment 4 Mike A. Harris 2001-02-17 02:02:00 EST
Cool, that would be great.  You're doing a great job with bugzilla Dave,
keep up the great work!  You're very quick to implement new ideas!
Makes life in bugzilla much more productive indeed.
Comment 5 Mike A. Harris 2001-02-17 11:29:46 EST
Oops, I went to attach a screenshot, and attached it to the wrong bug.
Don't know how (if possible) to fix this, so I'll just guide you to the
other bug.  ;o)  Bug #28052 has the screenshot.  Is there a way of
referencing an attachment from another bug in bugzilla?  Like saying
something like - attachment number id=10260 pertains to this as well..
Comment 6 Mike A. Harris 2002-06-22 00:54:52 EDT
ping

;o)
Comment 7 Mike A. Harris 2003-02-05 00:22:00 EST
Just cleaning up old bug report submissions I don't want to track anymore.
Closing bug out.

Note You need to log in before you can comment on or make changes to this bug.