Bug 27969 - hwaddr not retreived for tulip NIC
hwaddr not retreived for tulip NIC
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-16 11:32 EST by Tammy Fox
Modified: 2007-04-18 12:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 11:28:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v output for the tulip card (298 bytes, text/plain)
2001-02-16 12:39 EST, Trond Eivind Glomsrxd
no flags Details

  None (edit)
Description Tammy Fox 2001-02-16 11:32:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686)


I installed the latest test tree. I have a tulip NIC. When I run
ifconfig, the HWaddr says 00:00:00:00:0:0 thus breaking my static IP
address through dhcp based on my MAC address. The card seems to work other
than that, but I haven't done any load testing. This has happened in two
machines with a tulip NIC. I am not sure it is happens on other cards. 

Reproducible: Always
Steps to Reproduce:
1. Install latest test tree on a system with a tulip card.
2. Run ifconfig
3. Look at HWaddr
Comment 1 Michael K. Johnson 2001-02-16 12:00:56 EST
Arjan, since you have been working on tulip, I assume this
is related.
Comment 2 Trond Eivind Glomsrxd 2001-02-16 12:39:37 EST
Created attachment 10241 [details]
lspci -v output for the tulip card
Comment 3 Tammy Fox 2001-02-16 12:40:22 EST
Output of lspci -v :

00:0a.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 22)
	Subsystem: Netgear FA310TX Fast Ethernet
	Flags: bus master, medium devsel, latency 64, IRQ 10
	I/O ports at e800 [size=128]
	Memory at ea000000 (32-bit, non-prefetchable) [size=128]
	Expansion ROM at e9000000 [disabled] [size=256K]
Comment 4 Michael K. Johnson 2001-02-16 12:41:13 EST
lspci output from mgalgoci:
02:0b.0 Ethernet controller: Bridgecom, Inc: Unknown device 0985 (rev 11)
        Subsystem: Bridgecom, Inc: Unknown device 0574
        Flags: bus master, medium devsel, latency 64, IRQ 19
        I/O ports at e800 [size=256]
        Memory at fafff800 (32-bit, non-prefetchable) [size=1K]
        Expansion ROM at fb000000 [disabled] [size=128K]
        Capabilities: [c0] Power Management version 2
Comment 5 Trond Eivind Glomsrxd 2001-02-16 12:48:18 EST
Output from lspci -n:

[teg@halden teg]$ cat pcin
00:00.0 Class 0600: 8086:7190 (rev 03)
00:01.0 Class 0604: 8086:7191 (rev 03)
00:04.0 Class 0601: 8086:7110 (rev 02)
00:04.1 Class 0101: 8086:7111 (rev 01)
00:04.2 Class 0c03: 8086:7112 (rev 01)
00:04.3 Class 0680: 8086:7113 (rev 02)
00:0a.0 Class 0200: 11ad:0002 (rev 21)
01:00.0 Class 0300: 1002:475a (rev 7a)
[teg@halden teg]
Comment 6 Matthew Galgoci 2001-02-16 12:51:36 EST
Here is the lspci -n from my workstation with the broadcom card:

00:00.0 Class 0600: 8086:1a21 (rev 01)
00:01.0 Class 0604: 8086:1a23 (rev 01)
00:1e.0 Class 0604: 8086:2418 (rev 02)
00:1f.0 Class 0601: 8086:2410 (rev 02)
00:1f.1 Class 0101: 8086:2411 (rev 02)
00:1f.2 Class 0c03: 8086:2412 (rev 02)
00:1f.3 Class 0c05: 8086:2413 (rev 02)
01:00.0 Class 0300: 102b:0525 (rev 04)
02:04.0 Class 0200: 10b7:9200 (rev 78)
02:08.0 Class 0401: 1102:0002 (rev 07)
02:08.1 Class 0980: 1102:7002 (rev 07)
02:0b.0 Class 0200: 1317:0985 (rev 11)
02:0e.0 Class 0604: 1011:0024 (rev 03)

--Matt
Comment 7 Glen Foster 2001-02-17 18:31:41 EST
We (Red Hat) should really try to resolve this before next release.
Comment 8 Tim Waugh 2001-02-20 11:28:16 EST
2.4.2-pre4 [Linux tulip driver version 0.9.13a (January 20, 2001)] works for
me.  I'm looking at the changes between this and 0.9.13b.
Comment 9 Arjan van de Ven 2001-02-20 13:33:37 EST
Fixed for the next kernel build. Please test kernel versions 2.4.1-0.1.12 or
later, once available, and reopen this bug if the problem is not fixed for you.
Comment 10 Michael K. Johnson 2001-02-21 10:59:37 EST
Actually, test 2.4.1-0.1.13 or later; 0.1.12 had a typo

Note You need to log in before you can comment on or make changes to this bug.