Bug 279921 - apt no longer working (assertion)
apt no longer working (assertion)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 21:51 EDT by Jochen Schlick
Modified: 2008-01-12 04:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-12 04:53:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jochen Schlick 2007-09-05 21:51:05 EDT
Description of problem:
Calling 2 times apt-get update then I get the following result. 

hellraiser:/ # apt-get update
Get:1 http://download.fedora.redhat.com fedora/linux/development/i386/os/
repomd.xml [2142B]
Fetched 2142B in 1s (1321B/s)
Get:1 http://download.fedora.redhat.com fedora/linux/development/i386/os/
primary.sqlite [5330kB]
Get:2 http://download.fedora.redhat.com fedora/linux/development/i386/os/
filelists.sqlite [8551kB]
38% [1 primary bzip2 0] [2 filelists 1368/8551kB 0%]bzip2: (stdin) is not a
bzip2 file.
Err http://download.fedora.redhat.com fedora/linux/development/i386/os/
primary.sqlite
  Sub-process bzip2 returned an error code (2)
Get:3 http://download.fedora.redhat.com fedora/linux/development/i386/os/
primary.sqlite [5330kB]
Get:4 http://download.fedora.redhat.com fedora/linux/development/i386/os/
filelists.sqlite [8551kB]
69% [2 filelists bzip2 784384] [4 filelists 0/8551kB 0%]             186kB/s 45s
bzip2: Compressed file ends unexpectedly;
        perhaps it is corrupted?  *Possible* reason follows.
bzip2: Inappropriate ioctl for device
        Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

Err http://download.fedora.redhat.com fedora/linux/development/i386/os/
filelists.sqlite
  Sub-process bzip2 returned an error code (2)
69% [3 primary bzip2 0] [4 filelists 217096/8551kB 2%]               186kB/s
44sbzip2: (stdin) is not a bzip2 file.
Err http://download.fedora.redhat.com fedora/linux/development/i386/os/
primary.sqlite
  Sub-process bzip2 returned an error code (2)
Fetched 17.1MB in 1m36s (178kB/s)
Failed to fetch
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/repodata/primary.sqlite
 Sub-process bzip2 returned an error code (2)
Failed to fetch
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/repodata/filelists.sqlite
 Sub-process bzip2 returned an error code (2)
Failed to fetch
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/repodata/primary.sqlite
 Sub-process bzip2 returned an error code (2)
Reading Package Lists... Done
Building Dependency Tree... Done
E: Some index files failed to download, they have been ignored, or old ones used
instead.



hellraiser:/ # apt-get update
Get:1 http://download.fedora.redhat.com fedora/linux/development/i386/os/
repomd.xml [2142B]
Fetched 2142B in 0s (3315B/s)
Get:1 http://download.fedora.redhat.com fedora/linux/development/i386/os/
primary.sqlite [5330kB]
Hit http://download.fedora.redhat.com fedora/linux/development/i386/os/
filelists.sqlite
Get:2 http://download.fedora.redhat.com fedora/linux/development/i386/os/
primary.sqlite [5330kB]
Hit http://download.fedora.redhat.com fedora/linux/development/i386/os/
filelists.sqlite
99% [Working]                                                         888kB/s 0s
bzip2: Compressed file ends unexpectedly;
        perhaps it is corrupted?  *Possible* reason follows.
bzip2: Resource temporarily unavailable
        Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

Err http://download.fedora.redhat.com fedora/linux/development/i386/os/
primary.sqlite
  Could not open file
/var/lib/apt/lists/partial/download.fedora.redhat.com_pub_fedora_linux_development_i386_os_repodata_primary.sqlite
- open (2 No such file or directory)
Fetched 5330kB in 35s (150kB/s)
Failed to fetch
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/repodata/primary.sqlite
 Could not open file
/var/lib/apt/lists/partial/download.fedora.redhat.com_pub_fedora_linux_development_i386_os_repodata_primary.sqlite
- open (2 No such file or directory)
apt-get: rpm/rpmindexfile.cc:639: std::string
rpmRepomdIndex::IndexURI(std::string) const: Assertion `Res.size() > 0' failed.
Aborted

######################
Version-Release number of selected component (if applicable):
apt-0.5.15lorg3.93-2.fc8.i386.rpm

######################
How reproducible:
yes

#######################
Steps to Reproduce: (with download.fedora.redhat.com as repomd source)
1. apt-get update
2. apt-get update 
and then I get the assertion
Comment 1 Panu Matilainen 2007-09-13 05:32:22 EDT
I'm not able to reproduce that, but it seems that in order to trigger the assert
the download has to fail to begin with (you seem to be getting partial downloads
which bzip then fails to handle, naturally). Dunno how to reproduce that
reliably... 

Anyway, I should be able to figure out a nicer way to deal with the failed
download based on the above information. I'll have a look when I find the time...
Comment 2 Panu Matilainen 2008-01-12 04:53:07 EST
This should be fixed in 0.5.15lorg3.94, in rawhide now, but feel free to reopen
if it still happens...

Note You need to log in before you can comment on or make changes to this bug.