Bug 280001 - phpdoc has broken dependencies in epel5
phpdoc has broken dependencies in epel5
Status: CLOSED WORKSFORME
Product: Fedora EPEL
Classification: Fedora
Component: php-pear-PhpDocumentor (Show other bugs)
el5
All Linux
medium Severity low
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 00:29 EDT by Kevin Fenzi
Modified: 2007-09-14 17:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 16:01:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2007-09-06 00:29:46 EDT
package: phpdoc - 1.3.2-1.el5.noarch from epel
  unresolved deps: 
     php-pear(PhpDocumentor) = 0:1.3.2-1.el5
Comment 1 Kevin Fenzi 2007-09-12 19:20:57 EDT
I have removed php-pear-PhpDocumentor from the epel-5 stable repository for now. 

If you can get the dep fixed up in testing we can push it out again. 
Comment 2 Konstantin Ryabitsev 2007-09-14 16:01:57 EDT
Unless I'm mistaken, the latest version in EPEL is (was) 1.3.2-2.el5. One of my
currently running systems confirms this:

root@devserv:[~]# rpm -qi phpdoc
Name        : phpdoc                       Relocations: (not relocatable)
Version     : 1.3.2                             Vendor: Fedora Project
Release     : 2.el5                         Build Date: Tue 12 Jun 2007 05:11:54
PM EDT
Install Date: Thu 05 Jul 2007 03:17:36 PM EDT      Build Host:
ppc1.fedora.redhat.com
Group       : Development/Tools             Source RPM:
php-pear-PhpDocumentor-1.3.2-2.el5.src.rpm
Size        : 27738                            License: LGPL
Signature   : DSA/SHA1, Thu 14 Jun 2007 08:14:55 AM EDT, Key ID 119cc036217521f6
Packager    : Fedora Project <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.phpdoc.org/
Summary     : Command-line utility for PhpDocumentor
Description :
This package includes a utility to run PhpDocumentor from the command-line
interface.

root@devserv:[~]# rpm -q --requires phpdoc
/usr/bin/php  
php-cli  
php-pear-PhpDocumentor = 1.3.2-2.el5
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

The fact that it magically downgraded itself to the previous version is not
really my fault. I'm rebuilding the correct version, so whenever it completes,
it can be pushed (again, and hopefully it won't self-downgrade this time).
Comment 3 Kevin Fenzi 2007-09-14 17:09:57 EDT
Ah ha. Sorry about this. I think I see the issue. 

The repo keeps around 2 copies of each package, the current version and the
previous one. My check was running checking all the packages, not just the most
recent one, and the -1 version of this package had a dependency problem. ;( 

Sorry for removing it when it wasn't at fault. I should have just removed the
older version. ;( 

Note You need to log in before you can comment on or make changes to this bug.