Bug 280411 - Need to fix modprobe to default to operating in non-blocking mode
Summary: Need to fix modprobe to default to operating in non-blocking mode
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: module-init-tools   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Jon Masters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 583989
TreeView+ depends on / blocked
 
Reported: 2007-09-06 13:32 UTC by Neil Horman
Modified: 2010-04-20 13:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 583989 (view as bug list)
Environment:
Last Closed: 2009-01-20 20:54:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0093 normal SHIPPED_LIVE module-init-tools bug fix and enhancement update 2009-01-20 16:04:29 UTC

Description Neil Horman 2007-09-06 13:32:15 UTC
Description of problem:
modprobe differs from rmmod currently in that, by default, it operates in
blocking mode.  This can lead to deadlock, since modprobe holds fcntl locks on
modules its removing, and can wind up blocking in the kernel, waiting on modules
requesting that the same module be added.  See:
http://www.ussg.iu.edu/hypermail/linux/kernel/0709.0/0890.html
For details.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
see http://www.ussg.iu.edu/hypermail/linux/kernel/0709.0/0890.html
  

Additional info:
This patch in conjunction with the other posted kernel patch will solve the issue:
http://www.ussg.iu.edu/hypermail/linux/kernel/0709.0/0897.html

Comment 1 RHEL Product and Program Management 2008-07-21 23:09:30 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 3 RHEL Product and Program Management 2008-07-28 19:52:44 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Jon Masters 2008-09-18 00:00:58 UTC
In module-init-tools-3_3-0_pre3_1_38_el5

Comment 9 errata-xmlrpc 2009-01-20 20:54:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0093.html


Note You need to log in before you can comment on or make changes to this bug.