Bug 280491 - Won't install a i386 package if x86_64 is already installed
Won't install a i386 package if x86_64 is already installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 09:54 EDT by Bill Nottingham
Modified: 2014-03-16 23:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.2.5-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 23:20:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-09-06 09:54:06 EDT
Description of problem:

If I've got a x86_64 package installed, and I want to install a i386 version of
it for compat, yum refuses to install it.

[root@nostromo Desktop]# rpm -q --qf "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"
pulseaudio-lib
pulseaudio-lib-0.9.7-0.10.svn20070905.fc8.x86_64

[root@nostromo Desktop]# yum install
pulseaudio-lib-0.9.7-0.10.svn20070905.fc8.i386.rpm 
Loading "skip-broken" plugin
Setting up Install Process
Parsing package install arguments
Examining pulseaudio-lib-0.9.7-0.10.svn20070905.fc8.i386.rpm: pulseaudio-lib -
0.9.7-0.10.svn20070905.fc8.i386
pulseaudio-lib-0.9.7-0.10.svn20070905.fc8.i386.rpm: does not update installed
package.
Nothing to do

rpm installs it fine:

[root@nostromo Desktop]# rpm -ivh
pulseaudio-lib-0.9.7-0.10.svn20070905.fc8.i386.rpm 
Preparing...                ########################################### [100%]
   1:pulseaudio-lib         ########################################### [100%]

Version-Release number of selected component (if applicable):

yum-3.2.4-3.fc8
Comment 1 Seth Vidal 2007-09-06 15:29:57 EDT
committed to upstream - 

patch here:
http://devel.linux.duke.edu/gitweb/?p=yum.git;a=commitdiff;h=824e72a0cf1ef19c046ed4139a109173aa516e80
Comment 2 Fedora Update System 2007-09-12 12:41:14 EDT
yum-3.2.5-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2007-09-17 23:20:45 EDT
yum-3.2.5-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.