Bug 281101 - Segmentation Fault when compiling mu-conference plug-in for jabberd
Segmentation Fault when compiling mu-conference plug-in for jabberd
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 14:10 EDT by Harold Pritchett
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 13:40:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed Source (269.83 KB, text/plain)
2007-09-06 14:18 EDT, Harold Pritchett
no flags Details

  None (edit)
Description Harold Pritchett 2007-09-06 14:10:08 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Harold Pritchett 2007-09-06 14:18:10 EDT
Created attachment 189061 [details]
Preprocessed Source
Comment 2 Harold Pritchett 2007-09-06 14:19:40 EDT
Segmentation foult when compiling mu-conference plugin for jabberd.

Output from "make" command

[root@lists mu-conference_0.7]# make
cd src/ ; make
make[1]: Entering directory `/home/harold/mu-conference_0.7/src'
cd jabberd ; make 
make[2]: Entering directory `/home/harold/mu-conference_0.7/src/jabberd'
gcc -O2 -Wall -I. -I../../include `pkg-config --cflags glib-2.0` -D_REENTRANT
-DLIBIDN   -c -o expat.o expat.c
expat.c: In function 'xmlnode_put_expat_attribs':
expat.c:219: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccfx854G.out file, please attach this to
your bugreport.
make[2]: *** [expat.o] Error 1
make[2]: Leaving directory `/home/harold/mu-conference_0.7/src/jabberd'
make[1]: *** [libjcomp.a] Error 2
make[1]: Leaving directory `/home/harold/mu-conference_0.7/src'
make: *** [all] Error 2
[root@lists mu-conference_0.7]# uname -m
x86_64
Comment 3 Adrian Reber 2007-09-06 14:27:00 EDT
Reassigning to jakub as this seems to be gcc and not jabberd
Comment 4 Harold Pritchett 2007-09-06 14:27:57 EDT
Instructions for installing the mu-conferencing plugin were found at:

http://jabberd2.xiaoka.com/wiki/InstallGuide/MU-Conferencing

An excerpt from this page shows the following prerequisites:

For MU-conference 0.7 or better, libglib-2, expat and libidn11

My system has:

[root@lists harold]# rpm -qa | egrep "glib|expat|libind"
glib-java-0.2.6-3.fc6
avahi-glib-0.6.16-4.fc6
dbus-glib-devel-0.70-6.fc6
expat-1.95.8-8.2.1
expat-1.95.8-8.2.1
glibc-devel-2.5-18.fc6
expat-devel-1.95.8-8.2.1
glib2-2.12.9-1.fc6
NetworkManager-glib-0.6.4-5.fc6
NetworkManager-glib-0.6.4-5.fc6
glib2-devel-2.12.9-1.fc6
glibmm24-2.12.8-1.fc6
glibc-common-2.5-18.fc6
glib-1.2.10-26.fc6
dbus-glib-0.70-6.fc6
glibc-2.5-18.fc6
glibc-headers-2.5-18.fc6
glib-java-0.2.6-3.fc6
avahi-glib-0.6.16-4.fc6
glibc-2.5-18.fc6
jakarta-taglibs-standard-1.1.1-7jpp.1
expat-devel-1.95.8-8.2.1
glib2-2.12.9-1.fc6
glibc-devel-2.5-18.fc6
dbus-glib-0.70-6.fc6
glib2-devel-2.12.9-1.fc6
jakarta-taglibs-standard-javadoc-1.1.1-7jpp.1
Comment 5 Harold Pritchett 2007-09-06 14:57:16 EDT
Delete comment #4 and replace with this one:

Instructions for installing the mu-conferencing plugin were found at:

http://jabberd2.xiaoka.com/wiki/InstallGuide/MU-Conferencing

An excerpt from this page shows the following prerequisites:

For MU-conference 0.7 or better, libglib-2, expat and libidn11

My system has:

[root@lists harold]# rpm -qa | egrep "glib|expat|libidn"
glib-java-0.2.6-3.fc6
avahi-glib-0.6.16-4.fc6
dbus-glib-devel-0.70-6.fc6
expat-1.95.8-8.2.1
libidn-devel-0.6.5-1.1
expat-1.95.8-8.2.1
glibc-devel-2.5-18.fc6
libidn-0.6.5-1.1
expat-devel-1.95.8-8.2.1
glib2-2.12.9-1.fc6
NetworkManager-glib-0.6.4-5.fc6
NetworkManager-glib-0.6.4-5.fc6
glib2-devel-2.12.9-1.fc6
glibmm24-2.12.8-1.fc6
glibc-common-2.5-18.fc6
glib-1.2.10-26.fc6
dbus-glib-0.70-6.fc6
glibc-2.5-18.fc6
glibc-headers-2.5-18.fc6
glib-java-0.2.6-3.fc6
avahi-glib-0.6.16-4.fc6
glibc-2.5-18.fc6
jakarta-taglibs-standard-1.1.1-7jpp.1
expat-devel-1.95.8-8.2.1
glib2-2.12.9-1.fc6
libidn-0.6.5-1.1
glibc-devel-2.5-18.fc6
dbus-glib-0.70-6.fc6
glib2-devel-2.12.9-1.fc6
jakarta-taglibs-standard-javadoc-1.1.1-7jpp.1
[root@lists harold]# 
Comment 6 Jakub Jelinek 2007-09-10 13:40:51 EDT
Can't reproduce with neither gcc-4.1.2-13.fc6 nor gcc-4.1.2-12.
Comment 7 Harold Pritchett 2007-09-10 20:30:31 EDT
I can reproduce this every time.  What can I do to find the problem with my system?
Comment 8 Jakub Jelinek 2007-09-11 05:40:06 EDT
If so, start with
rpm -q gcc
rpm -V gcc cpp
Ensure you can reproduce it with the preprocessed source you have attached.
 
Comment 9 Harold Pritchett 2007-09-12 13:45:39 EDT
Thanks for the ideas.  Actually, I re-booted the machine (It's a production
machine and I have to schedule a re-boot) and then the compile worked.

Don't know why it wouldn't work before the re-boot.

Note You need to log in before you can comment on or make changes to this bug.