Bug 28130 - Install fails during format - anaconda
Install fails during format - anaconda
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-17 00:06 EST by dan sherwin
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 16:37:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dump from failed install - anaconda (781 bytes, text/plain)
2001-02-17 00:07 EST, dan sherwin
no flags Details
anaconda fails during upgrade or installtion (952 bytes, text/plain)
2001-02-24 10:28 EST, nagaraj
no flags Details

  None (edit)
Description dan sherwin 2001-02-17 00:06:31 EST
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1470, in 
doInstall
    self.fstab.turnOnSwap()
  File "fstab.py", line 408, in turnOnSwap
    isys.swapon (file)
  File "isys.py", line 142, in swapon
    return _isys.swapon (path)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
path: /tmp/swap/hda5

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 dan sherwin 2001-02-17 00:07:17 EST
Created attachment 10280 [details]
dump from failed install - anaconda
Comment 2 Michael Fulbright 2001-02-19 12:13:15 EST
Looks like bug 17791.

Were you trying to mount a swap partition?
Comment 3 dan sherwin 2001-02-21 20:33:31 EST
I tried the install 2 ways.  The first was lettting the install format the 
partions and remove data automatically.  The second time I setup the partions 
manually.  Same error both ways.  What next?

Thanks.

Dan
Comment 4 nagaraj 2001-02-24 10:28:22 EST
Created attachment 10943 [details]
anaconda fails during upgrade or installtion
Comment 5 Michael Fulbright 2001-02-27 15:16:44 EST
I cannot reproduce this - it would really help to have step by step instructions
on how to reproduce this issue.
Comment 6 dan sherwin 2001-02-27 16:37:34 EST
I had 2 disks in the system.  It was a real f...ing pain to get them configured 
with RH6.0.  I simply deleted all partions and setup one disk and it's all good 
now.  The disk I'm having trouble with is like 10 years old.  You can close the 
call, thanks for your help!!

Dan
Comment 7 Michael Fulbright 2001-02-27 18:00:08 EST
Ok thanks for the feedback.  If you experience any additional problems please
reopen a bug and we'll take a look!

Note You need to log in before you can comment on or make changes to this bug.