Bug 28141 - netcfg hangs system
netcfg hangs system
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: netcfg (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-17 09:58 EST by Bill Stephens
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-22 13:35:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Stephens 2001-02-17 09:58:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


When trying to launch netcfg from gnome, the entire system hangs (freezes, 
locks up, non responsive, no keyboard or mouse possible).

Reproducible: Always
Steps to Reproduce:
1.Start X (using gnome, haven't tried anything else)
2.launch netcfg
3.completely hung at this point
	

Actual Results:  hard system hang

Expected Results:  netcfg should have launched

I'm testing on a Dell 2400, with Dual 866 SMP configuration.  The adapters 
installed are AMI Megaraid (perc2/dc),IBM PCI token ring adapter 
(olympic), 3com 3c905c-tx, adaptec a7xxx (for tape and cd).  The system is 
configured with 512mb memory.  The problem is easily reproduceable.
Comment 1 Glen Foster 2001-02-17 18:31:45 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Nalin Dahyabhai 2001-02-20 11:47:21 EST
What kind of video card do you have?  Can you access the affected system over
the network?  I can't reproduce this on my test system.
Comment 3 Bill Stephens 2001-02-20 12:06:17 EST
My video is an ATI Rage 3d (mach 64 driver).  I'm suspecting 2.4 kernel 
problems either with PCI or Token-Ring on the Dell servers.  The Dell 2400's 
have 2 seperate busses, and when I try to insmod the olympic driver by itself, 
I get an error indicating (I don't have the exact text handy) that it's having 
problems with the PCI interrupt.
-Bill
Comment 4 Bill Stephens 2001-02-20 12:07:24 EST
My video is an ATI Rage 3d (mach 64 driver).  I'm suspecting 2.4 kernel 
problems either with PCI or Token-Ring on the Dell servers.  The Dell 2400's 
have 2 seperate busses, and when I try to insmod the olympic driver by itself, 
I get an error indicating (I don't have the exact text handy) that it's having 
problems with the PCI interrupt.
-Bill
Comment 5 Nalin Dahyabhai 2001-02-21 16:41:02 EST
Does this only happen when a particular driver is loaded (i.e., the
aforementioned olympic driver)?  Does it continue if you update to the XFree86
and kernel packages from Raw Hide (ftp://ftp.redhat.com/pub/rawhide/)?
Comment 6 Bill Stephens 2001-02-22 13:35:04 EST
That seems to have helped netcfg.  It no longer hangs with the new kernel and 
xfree86.  I'm suspecting the kernel updates.  I'm still getting kernel panics 
though, but not as frequently.  I'll track that under my other bug report 
though.  You can close this one out as fixed with the new kernel and xfree86 
from rawhide.

Thanks,

Bill
Comment 7 Nalin Dahyabhai 2001-02-22 17:09:38 EST
Will do.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.