Bug 281621 - Setroubleshoot seems to be broken with latest audit
Setroubleshoot seems to be broken with latest audit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 18:44 EDT by Robert Scheck
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 17:28:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Changes the path of the socket (869 bytes, patch)
2007-09-06 18:46 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2007-09-06 18:44:44 EDT
Description of problem:
/var/run/audit_events does not exist on my system (assuming no longer), but
/var/run/audispd_events exists, so I changed the path.

Version-Release number of selected component (if applicable):
setroubleshoot-1.9.7-1

Actual/Expected results:
Working setroubleshoot like in the past. Because nevertheless setroubleshoot 
bails out:

2007-09-07 00:43:06,055 [avc.ERROR] exception MemoryError:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/setroubleshoot/avc_audit.py", line 
578, in run
    if not record.read_from_fd(self.audit_socket.fileno()):
  File "/usr/lib/python2.5/site-packages/setroubleshoot/avc_audit.py", line 80, 
in read_from_fd
    new_data = os.read(fd, self.length - len(self.body))
MemoryError

Can somebody please fix setroubleshoot soon?
Comment 1 Robert Scheck 2007-09-06 18:46:06 EDT
Created attachment 189311 [details]
Changes the path of the socket
Comment 2 John Dennis 2007-09-06 21:36:59 EDT
yes, we are aware the audit package and setroubleshoot is out of sync.
Unfortunately it's more than just the path of the socket. The protocol on the
socket changed too. We're working to update setroubleshoot to work with the new
protcol and an update should be available shortly. Thank you for reporting this.
Comment 3 John Dennis 2007-09-24 17:28:15 EDT
Current versions of audit and setroubleshoot should resolve this issue.

setroubleshoot-1.10.5-1.fc8
audit-1.6.1-2.fc8

the above two versions are known to work together, although I believe the issue
was resolved as early as setroubleshoot-1.10.3-1.fc8

Note You need to log in before you can comment on or make changes to this bug.