Bug 281711 - soundcard not found
soundcard not found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 20:59 EDT by John Ellson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 07:18:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log (62.44 KB, text/plain)
2007-09-06 20:59 EDT, John Ellson
no flags Details
scsrun.log (225 bytes, text/plain)
2007-09-06 21:02 EDT, John Ellson
no flags Details
screenshot of first page of SoundCardDetection (45.92 KB, image/png)
2007-09-10 17:11 EDT, John Ellson
no flags Details

  None (edit)
Description John Ellson 2007-09-06 20:59:49 EDT
Description of problem:
- sound card not found from "system -> administration -> soundcard detection"
- in spite of this, sound works for some apps, e.g. tvtime, but not others, e.g
secondlife

Version-Release number of selected component (if applicable):
system-config-soundcard-2.0.6-8.fc8.noarch

How reproducible:
100%

Steps to Reproduce:
1. system -> administration -> soundcard detection
2.
3.
  
Actual results:
Fails.  See logs attached.

Expected results:
Working sound

Additional info:
Sound was working until recently (1 week maybe?)
Comment 1 John Ellson 2007-09-06 20:59:49 EDT
Created attachment 189371 [details]
scsconfig.log
Comment 2 John Ellson 2007-09-06 21:02:17 EDT
Created attachment 189381 [details]
scsrun.log
Comment 3 Martin Stransky 2007-09-10 06:04:36 EDT
You have more than one audio device:

00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio
Controller (rev a2)
01:07.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio
Decoder (rev 05)
01:07.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and Audio
Decoder [MPEG Port] (rev 05)

Which one would you like to use? Drivers for CK804 AC'97 looks loaded fine. Can
you attach a screenshot of the first page of system-config-soundcard? (with the
detected devices).
Comment 4 John Ellson 2007-09-10 17:11:23 EDT
Created attachment 192061 [details]
screenshot of first page of SoundCardDetection
Comment 5 John Ellson 2007-09-10 17:18:51 EDT
I think the other device is just sound and video input from the TV card, which
still works.

I'd tell you more, but hwbrowser seems to be broken.  I'll file a bug on that next.

The sound device is on the MB.  I have no separate sound "card" in the system.
Comment 6 John Ellson 2007-09-15 17:20:54 EDT
Is this bug related to BZ#283371 by any chance?   
Comment 7 Martin Stransky 2007-09-27 10:22:28 EDT
I don't think so.

But the screenshot looks sane, does the sound work?

If not, can you please run the latest system-config-soundcard, switch to the
"System" page and try to "Reset configuration files"?

Comment 8 John Ellson 2007-09-27 22:51:29 EDT
There seems to be an awful lot of churn in the sound systems, but currently
system-config-soundcard is working for me.  It finds the nvidia sound device and
plays the test sound.    Its just a shame that nothing else seems to recognize
the device that was found.   The Volume control on the panel says it can't find
any elements or devices to control.   Tvtime, which used to have sound even when
system-config-soundcard didn't work, now can't access /dev/video because
something else broke the permissions!   If I chmod 666 /dev/video, the video
works but now no sound. Secondlife binaries, no sound.


Basically the sound system is a mess.   Fixing the entire sound system should be
a blocker for FC8!
Comment 9 John Ellson 2007-09-27 22:55:30 EDT
Oh yes, selecting "System" tab and "Reset configuration files" produces:
     Unable to remove kernel modules. You need to reboot your box
     for the changes to take effect.

"Reload audio drivers"  does the same thing.
Comment 10 Martin Stransky 2007-10-01 07:18:06 EDT
(In reply to comment #9)
> Oh yes, selecting "System" tab and "Reset configuration files" produces:
>      Unable to remove kernel modules. You need to reboot your box
>      for the changes to take effect.
> 
> "Reload audio drivers"  does the same thing.

It's not a bug. Your audio is used by some other application so the modules
can't be removed from kernel.

Okay, closing as fixed for now.


Note You need to log in before you can comment on or make changes to this bug.