Bug 281721 - SAMBA broken by the latest updates
SAMBA broken by the latest updates
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
7
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 21:01 EDT by Joshua Rosen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-09 01:35:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smb.conf file (7.61 KB, application/octet-stream)
2007-09-07 11:49 EDT, Joshua Rosen
no flags Details
updated smb.conf (10.25 KB, application/octet-stream)
2007-09-07 12:48 EDT, Joshua Rosen
no flags Details
nmbd log (758.12 KB, application/octet-stream)
2007-09-07 19:33 EDT, Joshua Rosen
no flags Details
smbd log (95.11 KB, application/octet-stream)
2007-09-07 19:34 EDT, Joshua Rosen
no flags Details

  None (edit)
Description Joshua Rosen 2007-09-06 21:01:45 EDT
Description of problem:SAMBA has stopped working. It was working fine on F7
until a recent update, now it's completely broken.


Version-Release number of selected component (if applicable):


How reproducible: 100%. I have two different systems where SAMBA no longer works.



Steps to Reproduce:
1. Start SMB and NMB daemons
2. 
3.
  
Actual results: Shares are not visable to W2K

Here is the log file results

Sep  6 20:51:31 wasp nmbd[2537]: [2007/09/06 20:51:31, 0]
nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(351) 
Sep  6 20:51:31 wasp nmbd[2537]:   find_domain_master_name_query_fail: 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to find the Domain Master Browser name
WORKGROUP<1b> for the workgroup WORKGROUP. 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to sync browse lists in this workgroup. 
Sep  6 20:51:31 wasp nmbd[2537]: [2007/09/06 20:51:31, 0]
nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(351) 
Sep  6 20:51:31 wasp nmbd[2537]:   find_domain_master_name_query_fail: 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to find the Domain Master Browser name
WORKGROUP<1b> for the workgroup WORKGROUP. 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to sync browse lists in this workgroup. 
Sep  6 20:51:31 wasp nmbd[2537]: [2007/09/06 20:51:31, 0]
nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(351) 
Sep  6 20:51:31 wasp nmbd[2537]:   find_domain_master_name_query_fail: 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to find the Domain Master Browser name
WORKGROUP<1b> for the workgroup WORKGROUP. 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to sync browse lists in this workgroup. 
Sep  6 20:51:31 wasp nmbd[2537]: [2007/09/06 20:51:31, 0]
nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(351) 
Sep  6 20:51:31 wasp nmbd[2537]:   find_domain_master_name_query_fail: 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to find the Domain Master Browser name
WORKGROUP<1b> for the workgroup WORKGROUP. 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to sync browse lists in this workgroup. 
Sep  6 20:51:31 wasp nmbd[2537]: [2007/09/06 20:51:31, 0]
nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(351) 
Sep  6 20:51:31 wasp nmbd[2537]:   find_domain_master_name_query_fail: 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to find the Domain Master Browser name
WORKGROUP<1b> for the workgroup WORKGROUP. 
Sep  6 20:51:31 wasp nmbd[2537]:   Unable to sync browse lists in this workgroup. 
Sep  6 20:51:46 wasp nmbd[2537]: [2007/09/06 20:51:46, 0] nmbd/nmbd.c:terminate(58) 
Sep  6 20:51:46 wasp nmbd[2537]:   Got SIGTERM: going down... 
Sep  6 20:53:24 wasp smbd[5532]: [2007/09/06 20:53:24, 0]
param/loadparm.c:map_parameter(2765) 
Sep  6 20:53:25 wasp smbd[5532]:   Unknown parameter encountered: "revalidate" 
Sep  6 20:53:25 wasp smbd[5532]: [2007/09/06 20:53:24, 0]
param/loadparm.c:lp_do_parameter(3505) 
Sep  6 20:53:26 wasp smbd[5532]:   Ignoring unknown parameter "revalidate" 
Sep  6 20:55:55 wasp nmbd[5536]: [2007/09/06 20:55:55, 0] nmbd/nmbd.c:terminate(58) 
Sep  6 20:55:55 wasp nmbd[5536]:   Got SIGTERM: going down... 
Sep  6 20:56:04 wasp smbd[6132]: [2007/09/06 20:56:04, 0]
param/loadparm.c:map_parameter(2765) 
Sep  6 20:56:05 wasp smbd[6132]:   Unknown parameter encountered: "revalidate" 
Sep  6 20:56:05 wasp smbd[6132]: [2007/09/06 20:56:04, 0]
param/loadparm.c:lp_do_parameter(3505) 
Sep  6 20:56:06 wasp smbd[6132]:   Ignoring unknown parameter "revalidate" 


Expected results:


Additional info:
Comment 1 Simo Sorce 2007-09-07 11:20:35 EDT
Can you pleas epost your smb.conf ?
Can you please specify exactly what version was working and what is the version
you are using now that does not work for you?

I see nmbd is getting a SIGTERM, can you please set up separate log files and
raise the log level to at least 5 ?
Comment 2 Joshua Rosen 2007-09-07 11:49:26 EDT
Created attachment 190071 [details]
smb.conf file
Comment 3 Simo Sorce 2007-09-07 12:06:00 EDT
A few comments.

- security = share is obsolete and not really well supported anymore. It's so
old that Microsoft has broken code in Vista that makes it not work with older
clients that use this method.

- are you really sure you want to be a WINS server? are your windows client
pointing to it ?

- is your workgroup name really WORKGROUP ?

- please do not use dots in the netbios name (wasp.samba) it confuses windows
clients which will try to use DNS to locate the machine.

- revalidate is an unknown option

can you give me the output of smbd -V ?
can you give me log level 5 log files?
Comment 4 Joshua Rosen 2007-09-07 12:48:00 EDT
Created attachment 190181 [details]
updated smb.conf
Comment 5 Joshua Rosen 2007-09-07 12:50:49 EDT
I removed and restored the SAMBA RPMs and regenerated a the smb.conf. I switched
to user security and I changed the server name to wasp from wasp.samba. It
didn't help. The workgroup is WORKGROUP, that's the MS default. I'm using SAMBA
to share directories with a VMware Win2K VM. I'm never going to be using VISTA
so I don't care about VISTA compatibility, I'm sticking with W2K for my VMs for
as long as I can.

smbd -V
Version 3.0.25c-0.fc7

How do I set the log level?

Here is the nmb.log

  Copyright Andrew Tridgell and the Samba Team 1992-2007
[2007/09/07 12:44:02, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
  *****
  
  Samba name server WASP is now a local master browser for workgroup WORKGROUP
on subnet 192.168.1.7
  
  *****
[2007/09/07 12:44:02, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
  *****
  
  Samba name server WASP is now a local master browser for workgroup WORKGROUP
on subnet 192.168.1.207
  
  *****
[2007/09/07 12:44:02, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
  *****
  
  Samba name server WASP is now a local master browser for workgroup WORKGROUP
on subnet 192.168.122.1
  
  *****
[2007/09/07 12:44:02, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
  *****
  
  Samba name server WASP is now a local master browser for workgroup WORKGROUP
on subnet 172.16.166.1
  
  *****
[2007/09/07 12:44:02, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
  *****
  
  Samba name server WASP is now a local master browser for workgroup WORKGROUP
on subnet 192.168.69.1
  
  *****



I've attached the latest smb.conf
Comment 6 Simo Sorce 2007-09-07 12:55:52 EDT
Can you pleas eprovide mor einfo on what is not working exactly?
Are you unable to just see shares?
But can you browse and see the samba server?
Are you just denied access to shares?
Comment 7 Joshua Rosen 2007-09-07 13:51:45 EDT
I can't see the server. The SAMBA server on a CentOS 5 system does appear so
it's not a problem with the Windows VM.

This was working until a couple of days ago. I did a yum update recently, there
was a SAMBA update, I'm pretty sure that's what broke it.
Comment 8 Simo Sorce 2007-09-07 16:16:44 EDT
Well it works for me, so it is probably a specific configuration or site issue,
I need the more info like the log files to understand if it is a samba issue at all.

please set log level =10 and max log size = 0 restart samba and try to browse
the network from windows.
Also from windows try to ping the server and try to access it using \\1.2.3.4
(the IP of your server), and see if this works.
When you are done attach the logs here.
Comment 9 Joshua Rosen 2007-09-07 19:33:05 EDT
Created attachment 190591 [details]
nmbd log
Comment 10 Joshua Rosen 2007-09-07 19:34:58 EDT
Created attachment 190601 [details]
smbd log
Comment 11 Joshua Rosen 2007-09-07 19:38:27 EDT
I put a log level = 10 into the smb.conf file and started SMB NMB. 

Pings from the DOS shell work fine. Browsing the network shows the CentOS SAMBA
machine but not the Fedora 7 machine. I don't know what you mean by \\ip. What's
the command line that you want me to execute?

Comment 12 Simo Sorce 2007-09-08 14:05:32 EDT
your system seem to be a multihoomed system with 4 subnet
at least one seem to be wrongly configured, it shouws an ip of 192.168.1.7 and a
broadcast of 192.168.255.255 while, by looking at other address you have on the
192.168. range it should probably be 192.168.1.255

A wrong subnet mask is often cause of problems in browsing, especially as you
seem to have configured a WINS server but no other machine in your network is
configured to use it, there fore nobody else except this samba server register
to its own WINS server. This means the only method to find it is to use
broadcast discovery messages.

Please can you check your interfaces are properly configured with the right
subnet mask and check if fixing that and restarting nmbd fixes your problem ?
Comment 13 Joshua Rosen 2007-09-08 21:48:23 EDT
Changing the subnet mask does fix the problem. I had the subnet mask set to
255.255.0.0 so that I could access other subnets. I have VMware VMs on several
machines. On some of them I'm using NAT rather than Bridging which puts the VMs
on different subnets. The reason I'm doing that is that the only way to
communicate with a VM when there is no physical network is by setting up the
virtual NICs with NAT, a Bridged network only works when the physical network is
up. The place where this matters in on a laptop which is sometimes running
standalone. As it turns out it's possible to use ssh tunneling to access VMs on
other systems that are using NAT, i.e. you ssh to the host and then ssh from the
host to the VM. VMs are the only reason I use SAMBA or NFS. VMware Server lacks
a facility for directly accessing the host's directories so you have to use
SAMBA for Windows VMs and NFS for Linux VMs.
Comment 14 Simo Sorce 2007-09-09 01:35:47 EDT
Ok, thanks for following up.
I am closing this as NOT a bug.

Note You need to log in before you can comment on or make changes to this bug.