Bug 282221 - gallery2 broken after yum update
gallery2 broken after yum update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 08:21 EDT by Josh Boyer
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 10:22:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Boyer 2007-09-07 08:21:31 EDT
Description of problem:

From David Woodhouse:

I updated gallery2 a while ago. Just noticed today that it seems to have
broken -- I had to log in to its admin interface and run through the
setup stuff again (although I don't think I actually _did_ anything).

I also seemed to need to move /usr/share/gallery2/config.php
to /etc/gallery2, then rename a
symlink /usr/share/gallery2/config.php.rpmnew which points to the new
location. That's the kind of thing that a %post script should handle,
surely?
Comment 1 John Berninger 2007-09-07 10:22:08 EDT
This is covered in the README.fedora.  I chose to not automate this for two
reasons - 1) you must go through an upgrade process via the web interface
anyway, 2) I was not sure how to make the %post script do this completely
without error for the 2.1 -> 2.2 upgrade as well as not do it for a 2.2 -> 2.2
release upgrade, so chose to err on the side of "don't muck with the config file
if you're not sure wtf will happen".

Note You need to log in before you can comment on or make changes to this bug.