Bug 282301 - s390utils uses /usr/bin/ binaries in initscripts
s390utils uses /usr/bin/ binaries in initscripts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: s390utils (Show other bugs)
4.5
All Linux
urgent Severity high
: rc
: ---
Assigned To: Phil Knirsch
Alexander Todorov
GSSApproved
: ZStream
Depends On:
Blocks: 428288 428289
  Show dependency treegraph
 
Reported: 2007-09-07 09:05 EDT by Bryn M. Reeves
Modified: 2015-03-04 20:19 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0778
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to use sed instead of tr (665 bytes, patch)
2007-09-08 09:52 EDT, Bryn M. Reeves
no flags Details | Diff

  None (edit)
Description Bryn M. Reeves 2007-09-07 09:05:04 EDT
Description of problem:
The zcfcpconf.sh script makes use of the "tr" command which is installed into
/usr/bin. Since this script configures Z-series fiber devices prior to local
file system check & mount this fails on hosts that have /usr configured as a
separate file system.

Version-Release number of selected component (if applicable):
s390utils-1.3.2-2.40.15, also exists in RHEL4.5 package.

How reproducible:
100%

Steps to Reproduce:
1. Configure a system with /usr as a separate file system (maybe on zfcp ;)
2. Boot the system

Or just read the script.

Actual results:
The pipeline in zfcpconf.sh that extracts configuration data from /etc/zfcp.conf
 fails because tr cannot be found. No zfcp devices are configured, possibly
causing the boot process to fail.

Expected results:
Zfcp devices are created as specified in /etc/zfcp.conf

Additional info:
This affects RHEL5 too - will clone.
Comment 2 Bryn M. Reeves 2007-09-08 09:52:00 EDT
Created attachment 190791 [details]
patch to use sed instead of tr

Brad's patch to use sed instead of tr.
Comment 4 RHEL Product and Program Management 2007-11-28 22:58:40 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Phil Knirsch 2008-04-08 09:29:43 EDT
Test packages can be found here:

http://people.redhat.com/pknirsch/downloads/s390utils/s390utils-1.3.2-2.40.16

Read ya, Phil
Comment 15 errata-xmlrpc 2008-07-24 16:08:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0778.html

Note You need to log in before you can comment on or make changes to this bug.