Bug 28231 - up2date can't load the rpm interface
up2date can't load the rpm interface
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-18 14:40 EST by David Lawrence
Modified: 2015-01-07 18:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 20:33:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2001-02-18 14:40:32 EST
up2date --help results in:
[root@athlon rhn]# up2date --help
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/libz.so.1: undefined symbol: sfset

all RPMs are:
rpm-4.0.2-0.38
rpm-python-4.0.2-0.38
gnorpm-0.95.1-7
rpm-build-4.0.2-0.38
rpmfind-1.6-4
rpm-devel-4.0.2-0.38

up2dates are:
up2date-2.3.1-1
up2date-gnome-2.3.1-1

zlib is:
zlib-1.1.3-18
Comment 1 Adrian Likins 2001-02-18 19:11:39 EST
odd, with all the same rpm,up2date, and zlib packages installed
on my machine, it seems to work fine.

Though, `nm /usr/lib/libz.so.1` doesnt sow "sfset" as a symbol.

I wonder if it's a python issue.

This with:

[root@dhcpd36 lib]# rpm -qa | grep rpm
rpm-build-4.0.2-0.38
rpm-4.0.2-0.38
rpm-devel-4.0.2-0.38
rpmlint-0.14-4
rpm-python-4.0.2-0.38
rpmdb-redhat-7.0-0.20000830
gnorpm-0.95.1-5
rpm2html-1.5-4
rpmfind-1.6-4

[root@dhcpd36 lib]# rpm -qa | grep zlib
zlib-1.1.3-22
zlib-devel-1.1.3-22

[root@dhcpd36 lib]# rpm -qa | grep up2date
up2date-gnome-2.3.1-1
up2date-2.3.1-1

[root@dhcpd36 lib]# rpm -qa | grep python 
python-tools-1.5.2-27nt
python-1.5.2-27nt
openssl-python-0.9.5a-14
python-ldap-1.9-3
python-docs-1.5.2-27nt
mod_python-2.7.1-2
rpm-python-4.0.2-0.38
pythonlib-1.27-1
python-xmlrpc-1.2.1-4
python-devel-1.5.2-27nt


The only thing I see different is probabaly the python packages.
I have a version of the 7.0 packages compiled without thread
support (i need it for mod_python...)

After installing all the python packages from the beta, It still
seems to work okay for me.

[root@dhcpd36 RPMS]# rpm -qa | grep
python                                                                            
python-tools-1.5.2-29
python-devel-1.5.2-29
openssl-python-0.9.5a-14
python-ldap-1.9-3
mod_python-2.7.1-2
rpm-python-4.0.2-0.38
python-docs-1.5.2-29
pythonlib-1.27-1
python-xmlrpc-1.2.1-4
python-1.5.2-29


the rpmmodule.so (what `import rpm` imports) doesnt seem to
make any references to "sfset" so I am a little confused.

[root@dhcpd36 site-packages]# pwd
/usr/lib/python1.5/site-packages
[root@dhcpd36 site-packages]# strings rpmmodule.so | grep -i sfset


Not sure whats going on. Possible ideas. Make sure there isnt
a rogue rpm.py or otherwise in the cwd, that up2date might be
pulling in.




Comment 2 Bill Nottingham 2001-02-19 00:41:45 EST
zlib-1.1.3-18 was one of the broken optimized ones. Does this happen on
the final beta4?
Comment 3 Cristian Gafton 2001-02-19 20:33:32 EST
Assigned QA to jturner
Comment 4 Preston Brown 2001-02-20 12:34:06 EST
he needed to install zlib.

Note You need to log in before you can comment on or make changes to this bug.