Bug 282321 - s390utils uses /usr/bin/ binaries in initscripts
s390utils uses /usr/bin/ binaries in initscripts
Status: CLOSED DUPLICATE of bug 279201
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: s390utils (Show other bugs)
5.1
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
GSSApproved
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 09:07 EDT by Bryn M. Reeves
Modified: 2015-03-04 20:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-08 09:48:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2007-09-07 09:07:19 EDT
+++ This bug was initially created as a clone of Bug #282301 +++

Description of problem:
The zcfcpconf.sh script makes use of the "tr" command which is installed into
/usr/bin. Since this script configures Z-series fiber devices prior to local
file system check & mount this fails on hosts that have /usr configured as a
separate file system.

Version-Release number of selected component (if applicable):
s390utils-1.3.2-2.40.15, also exists in RHEL4.5 package.

How reproducible:
100%

Steps to Reproduce:
1. Configure a system with /usr as a separate file system (maybe on zfcp ;)
2. Boot the system

Or just read the script.

Actual results:
The pipeline in zfcpconf.sh that extracts configuration data from /etc/zfcp.conf
 fails because tr cannot be found. No zfcp devices are configured, possibly
causing the boot process to fail.

Expected results:
Zfcp devices are created as specified in /etc/zfcp.conf

Additional info:
This affects RHEL5 too - will clone.
Comment 2 Bryn M. Reeves 2007-09-08 09:48:56 EDT

*** This bug has been marked as a duplicate of 279201 ***

Note You need to log in before you can comment on or make changes to this bug.