Bug 28243 - graphic lilo problems + lilo install prob
graphic lilo problems + lilo install prob
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-18 21:07 EST by David Wilson
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 15:31:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Wilson 2001-02-18 21:07:56 EST
1) graphical lilo does not obey timeout or delay options in /etc/lilo.conf.
   If I change this value or even comment out the timeout=50 line it still
   only waits approx 5 seconds before starting default image.
   I did remember to run lilo to reinstall the bootloader.

2) commenting out message= line in lilo.conf causes system to be
   unbootable with Error = 0x01 continually scrolling up screen.
   This was an attempt to turn off graphical mode to see if this
   was cause of #1 above. Nothing in the docs indicates that this
   is a bad idea... I cannot find any mention of graphical mode in
   /usr/share/docs/lilo-21.4.4/*.

3) When installing RedHat Linux you have the choice of putting lilo
   in the MBR or in your linux partition. On dual boot systems I put it
   in my Linux partition so that Microsoft does not trash it should I
   reinstall Windows XXX.

   The installer program fails to offer the option of making the Linux
   partition it put lilo into Active. This would be better at this point
   than relying on the user to do it when they partitioned with fdisk
   (I don't recall disk druid having that as an option [but I may be
   wrong - I use fdisk as disk druid never seems to give me the right
   mix of primary and logical partitions]).
Comment 1 Glen Foster 2001-02-21 10:07:11 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Trond Eivind Glomsrxd 2001-03-09 14:53:53 EST
I can't reproduce 1) or 2) with lilo-21.4.4-13. The last problem would be an
installer bug.

In the future, please file each bug separately - this make tracking and
assigning easier.
Comment 3 Matt Wilson 2001-03-16 18:05:25 EST
agreed on 1) and 2), we'll have to defer 3) until the new disk management
framework is in place.
Comment 4 Jeremy Katz 2001-11-27 16:21:10 EST
As of Red Hat Linux 7.2, we mark the Linux partition active if there isn't a
partition already marked active.  If you've got your Windows partition marked
active (which isn't the norm in my experience), then we won't change it because
changing it is unsafe.  If you need to, that's what fdisk is for.

Note You need to log in before you can comment on or make changes to this bug.