Bug 282731 - Liferea crashes on feed folder delete
Liferea crashes on feed folder delete
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
7
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 12:52 EDT by Michael De La Rue
Modified: 2007-12-08 09:44 EST (History)
0 users

See Also:
Fixed In Version: 1.4.8-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-08 09:44:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael De La Rue 2007-09-07 12:52:23 EDT
Description of problem:
By deleting a folder of feeds I can immediately crash liferea

Version-Release number of selected component (if applicable):
liferea-1.2.19-3.fc7

How reproducible:
seems to be every time

Steps to Reproduce:
1. start liferea fresh (to reproduce I did rm ~/.liferea_1.2/)
2. right click on "OSS" 
3. select delete
4. click yes on dialog which appears

  
Actual results:
liferea crashes with segmentation fault

Expected results:
feeds are deleted

Additional info:
a) it seems there are newer stable versions (e.g. 12.23) so I'm not reporting
this to upstream until verified with those.  

b) Full liferea output from run:
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files

(gecko:13113): GLib-CRITICAL **: g_hash_table_lookup: assertion `hash_table !=
NULL' failed

** (gecko:13113): CRITICAL **: itemlist_load: assertion `NULL != itemSet' failed

Liferea did receive signal 11 (Segmentation fault).
Comment 1 Jan 2007-10-03 18:05:41 EDT
I am experiencing this, too. Very unnerving, especially since liferea comes with
a promotional fedora/rh feed-folder which now clocks up my screen. ;-(
Comment 2 Michael De La Rue 2007-10-05 14:08:20 EDT
I found it possible to work around by deleting feeds one at a time then deleting
the empty folder.  
Comment 3 Brian Pepple 2007-12-01 18:23:01 EST
Are you still experiencing this bug in the 1.4.x branch?
Comment 4 Michael De La Rue 2007-12-08 09:28:06 EST
No;  on a self-compiled lifrea (I downloaded 1.4.9 but in "about" it claims to
be 1.4.8) I don't see this problem any more.  At least not immediately.  
Comment 5 Brian Pepple 2007-12-08 09:44:08 EST
ok, marking as fixed then.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.