Bug 28277 - Problem with test field for charset & deakdeys
Summary: Problem with test field for charset & deakdeys
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 7.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-19 11:15 UTC by Daniel Resare
Modified: 2005-10-31 22:00 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-05-12 12:48:01 UTC


Attachments (Terms of Use)

Description Daniel Resare 2001-02-19 11:15:22 UTC
If i select swedish keyboard layout and try the test-field for dead keys
it works as expected (dead keys enabled) but if i switch to 'disable dead
keys' and then switch back to 'dead keys' mode the testfield behaves as if
dead keys were disabled

Comment 1 Glen Foster 2001-02-21 15:12:44 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Brent Fox 2001-02-28 06:10:20 UTC
This is not an installer bug.  The installer calls a program called setxkbmap,
and the bug is really with this program.  setxkbmap is unable to re-enable
deadkeys if they have been disabled.  Reassigning to X.

Comment 3 Mike A. Harris 2001-03-19 04:04:27 UTC

*** This bug has been marked as a duplicate of 22760 ***

Comment 4 Mike A. Harris 2001-03-19 18:33:08 UTC
Reopening to mark the other bug as duplicate instead.

Comment 5 Mike A. Harris 2001-05-12 12:49:30 UTC
This was a bug in the way the installer called the setxkbmap program.
The installer has been fixed.  XFree86  cvs code recently changed
the behavior of setxkbmap also so that it discards the variant used
if the layout is changed.


Note You need to log in before you can comment on or make changes to this bug.