Bug 28280 - Upgrade from 6.2 to 7.0 miswrites lilo.conf
Summary: Upgrade from 6.2 to 7.0 miswrites lilo.conf
Status: CLOSED DUPLICATE of bug 31194
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-19 11:35 UTC by Nicolas CROISET
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 23:43:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas CROISET 2001-02-19 11:35:00 UTC
Hello,

I have installed first on this machine redhat 6.2  with an SCSI hard disk and I recomplile the kernel.

I have these entry on redhat linux 6.2 in /etc/lilo.conf
image=/vmlinuz
   label=linux
   root=/dev/sda1
   initrd=/boot/initrd-2.2.14-5.0.img
   read-only

After an upgrade on redhat 7.0, it was impossible to boot on the SCSI hard disk, I use the floppy disk to boot.

The reason was that the upgrade write this in /etc/lilo.conf

image=/vmlinuz
   label=linux
   root=/dev/sda1
   initrd=/boot/initrd-2.2.16-22.img
   read-only


It was better if the lines were :
image=/boot/vmlinuz
   label=linux
   root=/dev/sda1
   initrd=/boot/initrd-2.2.16-22.img
   read-only


And the best is also to add the old boot like :
image=/vmlinuz
   label=linux.rpmsave
   root=/dev/sda1
   initrd=/boot/initrd-2.2.14-5.0.img
   read-only

Bye.

Comment 1 Doug Ledford 2001-02-21 23:46:24 UTC
The upgrade rewrote the stanza for the default kernel (aka, vmlinuz) like it was
suppossed to, but didn't bother to make sure that the image= portion of the
stanza was correct before changing the initrd= portion of the stanza. 
Re-assigning this to the install people.

Comment 2 Michael Fulbright 2001-02-27 23:43:47 UTC
Worth checking this against Wolverine beta, assigning to an engineer.

Comment 3 Matt Wilson 2001-03-27 17:15:46 UTC
I fixed this.

*** This bug has been marked as a duplicate of 31194 ***


Note You need to log in before you can comment on or make changes to this bug.