Bug 283101 - setroubleshootd fails to start with selinux dbus socket write error
setroubleshootd fails to start with selinux dbus socket write error
Status: CLOSED DUPLICATE of bug 289371
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 16:04 EDT by Paul Jenner
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-15 13:16:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Jenner 2007-09-07 16:04:02 EDT
Description of problem:

Since most recent updates from updates-testing, setroubleshootd fails to start
with selinux dbus socket write errors.

[root@localhost ~]# service setroubleshoot start
Starting setroubleshootd:                                  [  OK  ]
[root@localhost ~]# service setroubleshoot status
setroubleshootd dead but pid file exists

[root@localhost ~]# grep setroubleshoot /var/log/messages | tail -1
Sep  7 20:59:57 localhost setroubleshoot: [rpc.ERROR] exception DBusException:
org.freedesktop.DBus.Error.AccessDenied: Failed to connect to socket
/var/run/dbus/system_bus_socket: Permission denied Traceback (most recent call
last):   File "/usr/lib/python2.5/site-packages/setroubleshoot/server.py", line
406, in RunFaultServer     setroubleshootd_dbus = SetroubleshootdDBus()   File
"/usr/lib/python2.5/site-packages/setroubleshoot/server.py", line 317, in
__init__     self.bus = dbus.SystemBus()   File
"/usr/lib/python2.5/site-packages/dbus/_dbus.py", line 201, in __new__    
private=private)   File "/usr/lib/python2.5/site-packages/dbus/_dbus.py", line
107, in __new__     bus = BusConnection.__new__(subclass, bus_type,
mainloop=mainloop)   File "/usr/lib/python2.5/site-packages/dbus/bus.py", line
121, in __new__     bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
DBusException: org.freedesktop.DBus.Error.AccessDenied: Failed to connect to
socket /var/run/dbus/system_bus_socket: Permission denied

sealert gives:

SELinux is preventing setroubleshootd (setroubleshootd_t) "write" to
system_bus_socket (system_dbusd_var_run_t).

Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -qf /etc/init.d/setroubleshoot 
setroubleshoot-server-1.10.1-1.fc7
[root@localhost ~]# rpm -qf /var/run/dbus
dbus-1.0.2-6.fc7
[root@localhost ~]# rpm -q selinux-policy-targeted
selinux-policy-targeted-2.6.4-40.fc7

How reproducible:

Always

Steps to Reproduce:
1. service setroubleshoot start
  
Actual results:

setroubleshoot fails to start with selinux dbus socket write error

Expected results:

setroubleshoot starts

Additional info:
Comment 1 John Dennis 2007-09-15 13:16:08 EDT
Thank you for reporting this. It's a known issue which can be solved by
upgrading your version of the selinux policy to 3.0.7-10 or higher.

*** This bug has been marked as a duplicate of 289371 ***

Note You need to log in before you can comment on or make changes to this bug.