Bug 28319 - anaconda custom install failure
anaconda custom install failure
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-19 11:56 EST by Jeff Bireley
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 12:40:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bireley 2001-02-19 11:56:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Error message is the same as bug 27817 EXCEPT that the KeyError is rsh 
instead of what's in that bug report.

Machine is dedicated Linux machine, no Windows partition, attempted 
Workstation CD-ROM booted installation first.  Primary and swap partitions 
are set up, and mount point is set in installation dialog.  After step 
where network information is entered, system fails and reboots (The error 
message flashes by so quickly I can't read it).  

Attemped to do both server and custom installation.  Error message in bug 
report 27817 appears but no local variable or to-do list appears.

Any suggestions?

Thanks!

Note: Version of software is the one included with the RedHat Linux 7 
Bible book.

Reproducible: Always
Steps to Reproduce:
Workstation Installation:

1. Boot from Linux CD
2. Select Workstation installation.
3. Set mount point for primary partition to /
4. Set format and check disk for errors option.
5. Enter network information
6. Click next
7. System attempts to start x-server, and then sends termination signal 
and reboots.

Server and Custom Installation:

1. Boot from Linux CD
2. Select Workstation installation.
3. Set mount point for primary partition to /
4. Set format and check disk for errors option.
5. Enter network information
6. Click next
7. Dialog box with error message appears.  Text is the same as bug 27817 
EXCEPT KeyError is rsh.
Comment 1 Jeff Bireley 2001-02-19 12:34:01 EST
I just retried the Workstation installation and tried to watch the error 
message as it flashed by - it gives an error reading the security policy file.  
That sounds like a bad CD media, right?  It's not a CD-R, but i supposed it 
could be damaged...
Comment 2 Jeff Bireley 2001-02-19 12:40:50 EST
Got the traceback message this time - here it is:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in 
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 463, in 
setScreen
    direction ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in 
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in 
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/package_gui.py", line 427, 
in getScreen
    self.todo.getCompsList()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 16, in 
readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
    self.readCompsFile(file, self.packages, arch, matchAllLang)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
    comp.addPackage(packages[l])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
    return self.packages[item]
KeyError: tclx

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 8579c08>
item: tclx

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 3 Michael Fulbright 2001-02-21 16:01:54 EST
This looks like a CD read error - the security file message is not a problem
though.  Its just a warning.

Note You need to log in before you can comment on or make changes to this bug.