Bug 28333 - iptables command does not cause ip_tables module to load
Summary: iptables command does not cause ip_tables module to load
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iptables   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-19 19:44 UTC by Jay Berkenbilt
Modified: 2007-04-18 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 06:23:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Berkenbilt 2001-02-19 19:44:35 UTC
The iptables command does not cause the ip_tables kernel module to load
automagically.  Is it supposed to?

# iptables -t nat -L
iptables v1.2: can't initialize iptables table `nat': iptables who? (do you
need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.

Once I manually load ip_tables, the table-specific modules get loaded
automatically as expected:

# modprobe ip_tables   
# lsmod
Module                  Size  Used by
ip_tables              10688   0  (unused)
autofs                 10784   1  (autoclean)
de4x5                  41120   1 
via-rhine              10592   1 
# iptables -t nat -L
Chain PREROUTING (policy ACCEPT)
target     prot opt source               destination         

Chain POSTROUTING (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         
# lsmod
Module                  Size  Used by
iptable_nat            13312   0  (autoclean) (unused)
ip_conntrack           13376   1  (autoclean) [iptable_nat]
ip_tables              10688   3  [iptable_nat]
autofs                 10784   1  (autoclean)
de4x5                  41120   1 
via-rhine              10592   1

Comment 1 Enrico Scholz 2001-02-21 11:14:08 UTC
That is because iptables.c reads the modprobe-command from
/proc/sys/kernel/modprobe. But there a trailing '\n' is appended and so iptables
tries to execute '/sbin/modprobe\n iptables', but '/sbin/modprobe\n' is not
existing.

The current CVS snapshot of iptables.c, rev.1.30 contains a fix
(http://pserver.samba.org/cgi-bin/cvsweb/netfilter/userspace/iptables.c.diff?r1=1.29&r2=1.30)

Comment 2 Jay Berkenbilt 2001-02-24 06:23:41 UTC
This bug is still present in Wolverine.

Comment 3 Bernhard Rosenkraenzer 2001-02-28 10:50:43 UTC
Fixed in 1.2.0-9


Note You need to log in before you can comment on or make changes to this bug.