Bug 283331 - anaconda traceback after formatting partitions
anaconda traceback after formatting partitions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 20:53 EDT by Sertaç Ö. Yıldız
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.5-15.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 22:30:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception report (52.98 KB, text/plain)
2007-09-07 20:53 EDT, Sertaç Ö. Yıldız
no flags Details
traceback from "import fedora" (14.30 KB, image/png)
2007-09-13 21:42 EDT, Sertaç Ö. Yıldız
no flags Details
anacdump.txt (52.52 KB, text/plain)
2007-09-13 22:08 EDT, Sertaç Ö. Yıldız
no flags Details

  None (edit)
Description Sertaç Ö. Yıldız 2007-09-07 20:53:23 EDT
boot.iso and stage2.img from rawhide of 07-Sep-2007 06:37 failed.
Comment 1 Sertaç Ö. Yıldız 2007-09-07 20:53:23 EDT
Created attachment 190631 [details]
exception report
Comment 2 Jeremy Katz 2007-09-09 21:42:09 EDT
This works fine for me.  It looks like what's going wrong is that the
installclass isn't getting set up properly.

Can you switch to tty2 and run
  PYTHONPATH=/usr/lib/anaconda:/usr/lib/anaconda/installclasses:/usr/lib/booty
python -c 'import fedora'
 
Comment 3 Sertaç Ö. Yıldız 2007-09-10 09:02:45 EDT
(In reply to comment #2)
> This works fine for me.

with tr_TR.UTF-8 locale?

I'm gonna try what what you suggested when test2 is available as it would be
closer to the stage2.img I tried. Current rawhide stage2.img is coming with
4K/s, making it hard to test an http install.
Comment 4 Jeremy Katz 2007-09-10 09:33:16 EDT
Locale shouldn't matter as far as syntax errors with python, which is what
importing the right installclass failed with (apparently) 
Comment 5 Sertaç Ö. Yıldız 2007-09-10 09:58:42 EDT
(In reply to comment #4)
> Locale shouldn't matter as far as syntax errors with python

It might not be the case for this one, but for turkish locale it matters in
peculiar ways, see bug #191096.
Comment 6 Jeremy Katz 2007-09-10 10:29:44 EDT
Well aware of the fun with turkish locales; still not going to lead to a syntax
error.
Comment 7 Sertaç Ö. Yıldız 2007-09-13 21:42:42 EDT
Created attachment 195401 [details]
traceback from "import fedora"

This is from f8t2.
Comment 8 Sertaç Ö. Yıldız 2007-09-13 22:08:33 EDT
Created attachment 195411 [details]
anacdump.txt
Comment 9 Jeremy Katz 2007-09-14 10:44:54 EDT
Fixed in python-2.5.1-11
Comment 10 Fedora Update System 2007-11-09 18:51:15 EST
python-2.5-15.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python'
Comment 11 Fedora Update System 2007-11-21 22:29:56 EST
python-2.5-15.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.