Bug 283531 - A lot of warnings on stdout/stderr
A lot of warnings on stdout/stderr
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-08 09:05 EDT by Matěj Cepl
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: evolution-2.12.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 12:44:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2007-09-08 09:05:09 EDT
Description of problem:
Sorry Matthew if this is a dup, but I cannot find anything interesting for my
evolution spitting a lot of warnings on stderr/stdout. Nothing serious happened,
but now it looks there is even more of them than usually:
[matej@viklef ~]$ evolution
CalDAV Eplugin starting up ...

(evolution:11783): evolution-mail-WARNING **: ignored this junk plugin: not
enabled or we have already loaded one

(evolution:11783): e-utils-WARNING **: Plugin 'Spamassassin zásuvný modul pro
nevyžádanou poštu' failed to load hook 'org.gnome.evolution.mail.junk:1.0'

(evolution:11783): Gtk-CRITICAL **: gtk_toggle_button_get_active: assertion
`GTK_IS_TOGGLE_BUTTON (toggle_button)' failed

(evolution:11783): e-utils-WARNING **: Cannot resolve symbol
'org_gnome_new_mail_config' in plugin
'/usr/lib/evolution/2.10/plugins/liborg-gnome-new-mail-notify.so' (not exported?)
BBDB spinning up...

(evolution:11783): GLib-GObject-WARNING **: gsignal.c:1669: signal
`source_selected' is invalid for instance `0x9775020'

(evolution:11783): GLib-GObject-WARNING **: gsignal.c:1669: signal
`source_selected' is invalid for instance `0x9775140'

GCJ PLUGIN: thread 0x8ab0458: NP_GetMIMEDescription
GCJ PLUGIN: thread 0x8ab0458: NP_GetMIMEDescription return
GCJ PLUGIN: thread 0x8ab0458: NP_GetValue
GCJ PLUGIN: thread 0x8ab0458: NP_GetValue: returning plugin name.
GCJ PLUGIN: thread 0x8ab0458: NP_GetValue return
GCJ PLUGIN: thread 0x8ab0458: NP_GetValue
GCJ PLUGIN: thread 0x8ab0458: NP_GetValue: returning plugin description.
GCJ PLUGIN: thread 0x8ab0458: NP_GetValue return
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
camel-Message: --
camel-Message: --
camel-Message: --

(Yes, I have a plenty of plugins loaded -- is there a sane way how to get a list
 of them and whether they are switched or not, or do I have to write them down
manually?)


Version-Release number of selected component (if applicable):
[matej@viklef ~]$ rpm -qa evolution\*
evolution-webcal-2.10.0-1.fc7
evolution-remove-duplicates-0.0.2-6.fc7
evolution-data-server-1.10.3.1-2.fc7
evolution-bogofilter-0.2.0-5.fc7
evolution-data-server-devel-1.10.3.1-2.fc7
evolution-2.10.3-4.fc7

How reproducible:
there is always some junk on stdout/stderr, these particular messages are just
this time snapshot.

Steps to Reproduce:
1.start evolution in terminal
2.
3.
  
Actual results:
see above

Expected results:
no output on stdout/stderr

Additional info:
Otherwise I cannot reproduce crashing I mentioned on IRC
Comment 1 Matthew Barnes 2007-09-08 21:42:29 EDT
A few of these warnings are fixed in the update that's sitting in Fedora Updates
Testing right now.  But yeah, the upstream developers often forget to turn off
debugging messages before shipping a release.

Unfortunately, every warning or message has to be tracked down individually.  A
good technique for tracking down at least the WARNING and CRITICAL messages is
to run Evolution in GDB with a breakpoint on the g_logv function, then print a
backtrace when the breakpoint is hit.

As for getting a list of plugins, look in /usr/lib/evolution/2.xx/plugins. 
Evolution loads all plugins except those listed in the GConf key
/apps/evolution/eplugins/disabled (if it exists).
Comment 2 Matěj Cepl 2007-09-10 07:54:09 EDT
Thanks, I will try to hunt them down. Setting to NEEDINFO for myself to remind
me, but otherwise this should be considered NOTABUG.
Comment 3 Matěj Cepl 2007-10-11 19:23:14 EDT
Aj jaj -- just to give myself more time.
Comment 4 Milan Crha 2008-02-12 06:02:45 EST
Matej, any progress on this?
Comment 5 Matěj Cepl 2008-02-12 12:44:34 EST
Yeah, it's fixed

Note You need to log in before you can comment on or make changes to this bug.