Bug 283691 - Multiple different specifications for /usr/local/Brother/lpd(/.*)? (system_u:object_r:cupsd_exec_t:s0 and system_u:object_r:bin_t:s0).
Multiple different specifications for /usr/local/Brother/lpd(/.*)? (system_u...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-08 15:33 EDT by Matěj Cepl
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 13:35:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2007-09-08 15:33:19 EDT
Description of problem:
On any manipulation with packages by yum (i.e., install, upgrade, remove) I get
this message on stdout:

/etc/selinux/targeted/contexts/files/file_contexts: Multiple different
specifications for /usr/local/Brother/lpd(/.*)? 
(system_u:object_r:cupsd_exec_t:s0 and system_u:object_r:bin_t:s0).


Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.6.4-41.fc7

How reproducible:
100%
Comment 1 Daniel Walsh 2007-09-11 09:18:02 EDT
Fixed in selinux-policy-targeted-2.6.4-42.fc7
Comment 2 Matěj Cepl 2007-09-18 01:39:20 EDT
No, it isn't. Having here selinux-policy-targeted-2.6.4-42.fc7 and the problem
is still the same. I had to edit
/etc/selinux/targeted/contexts/files/file_contexts manually to get rid of the
error message.
Comment 3 Daniel Walsh 2007-09-18 08:12:17 EDT
Could you try to reinstall the package again and see if there are two lines for
Brother?
Comment 4 Matěj Cepl 2007-09-18 08:45:25 EDT
[root@viklef ~]# rpm -e --nodeps selinux-policy-targeted
[root@viklef ~]# mv /etc/selinux/
config            restorecond.conf  semanage.conf     targeted/
[root@viklef ~]# rpm -Uvh selinux-policy-targeted-2.6.4-42.fc7.noarch.rpm 
Preparing...                ########################################### [100%]
   1:selinux-policy-targeted########################################### [100%]

Traceback (most recent call last):
  File "/usr/sbin/genhomedircon", line 29, in <module>
    import selinux
  File "/usr/lib/python2.5/site-packages/selinux.py", line 7, in <module>
    import _selinux
ImportError: /usr/lib/python2.5/site-packages/_selinux.so: undefined symbol:
fsetfilecon_raw
libsemanage.semanage_install_sandbox: genhomedircon returned error code 1.
[root@viklef ~]# cd /etc/selinux/targeted/contexts/files/
[root@viklef files]# grep Brother file_contexts 
/usr/local/Brother/lpd(/.*)?    system_u:object_r:bin_t:s0
/usr/local/Brother/inf(/.*)?    system_u:object_r:cupsd_rw_etc_t:s0
/usr/local/Brother/Printer/[^/]*/cupswrapper(/.*)?      system_u:object_r:bin_t:s0
[root@viklef files]# 

That backtrace above is slightly worrying me, but otherwise it seems to be
fixed. Is it right?
Comment 5 Daniel Walsh 2007-09-18 10:57:01 EDT
Yes that is right.

Make sure you are up to date on libselinux, policycoreutils, libsemanage.

Note You need to log in before you can comment on or make changes to this bug.