Bug 28373 - NFS install to Armada 1540DM laptop fails
NFS install to Armada 1540DM laptop fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-19 21:51 EST by David Wilson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 15:05:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Wilson 2001-02-19 21:51:37 EST
Install of fisher via NFS to Compaq Armada 1540DM laptop fails with "Out of
Memory" error.

System: 48MB RAM, 2GB HDD, Netcomm CardLan 10/100 PC Card (pcnet_cs driver)

Install options:
laptop, manual partitioning (25MB /boot, 128MB swap, 1.2GB /),
English (Australian) language, no Gnome, yes KDE, no games.

Symptom: very slow on package selection page (lots of network activity
after clicking next on account config page), after next is clicked X
eventually shuts down with error message:

<3>Out of Memory: Killed process 59 (anaconda).

On VC1 the following error messages are also visible:

WARNING: Unknown EDD version 0x1600 supported [2 times]

Gtk-CRITICAL **: file gtkwidget.c: line 3306 (gtk_widget_set_sensitive):
assertion `widget != NULL' failed [6 times]

Tried it a second time with updates disk and this time the system hung
after I clicked the next button on the account config screen (no mouse
movement, no virtual console switching but does respond to ping).
Comment 1 Glen Foster 2001-02-21 10:06:46 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Michael Fulbright 2001-02-21 17:36:11 EST
Try booting the installer with:

linux mem=32M

It should ask you to turn on swap early and then things should go more smoothly.
Comment 3 David Wilson 2001-02-21 21:53:19 EST
mem=32m fixed it. It turned on swap AND forced a text install (not sure which of
these two fixed the problem).

So, did installer's RAM usage creep up without the test for `small' RAM machines
getting updated or did no one consider a system with >32MB and <64MB?

RedHat Fisher installed successfully but when system rebooted after installation
completed it hung at the starting pcmcia stage. It appears installer left PCMCIA
subsystem in strange state because power cycling system allowed it to boot the
next time. This laptop has a Texas Instruments PCI1131 cardbus controller and my
ethernet card is only PCMCIA.
Comment 4 Michael Fulbright 2001-02-27 15:05:17 EST
We've made some changes to the memory usage pattern since Fisher. Please try
Wolverine and let us know if it works better.
Comment 5 David Wilson 2001-02-28 19:44:46 EST
Yes, problem is solved in wolverine. Thanks.

Note You need to log in before you can comment on or make changes to this bug.