Bug 283801 - iscsistart fails on initrd image.
iscsistart fails on initrd image.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iscsi-initiator-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-08 22:36 EDT by Kostas Georgiou
Modified: 2013-01-09 23:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-09 15:19:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kostas Georgiou 2007-09-08 22:36:11 EDT
iscsistart fails with the following error:
iscsistart: peeruser_unix: unknown local user with uid 0

It seems that iscsistart calls getpwuid which fails since neither the password
file or the nss modules are available.
Comment 1 Kostas Georgiou 2007-09-13 20:24:26 EDT
Is there any way to help? I would really love to get iSCSI root working again in
fedora :)
Comment 2 Mike Christie 2007-09-14 16:43:54 EDT
I am working on a patch. I should hopefully have something monday for you to test.
Comment 3 Kostas Georgiou 2007-10-04 19:20:46 EDT
Any luck yet? :)
Comment 4 Mike Christie 2007-10-05 02:22:09 EDT
I thought it was a problem like you described in the bug report, but for
iscsistart we do some hokey magic and compile iscsistart with:

statics.c:

static struct passwd root_pw = {
        .pw_name = "root",
};

struct passwd*
getpwuid(uid_t uid)
{
        if (uid == 0)
                return &root_pw;
        else {
                errno = ENOENT;
                return 0;
        }
}


Are you using the iscsi-initiator-utils iscsistart? And what version of
iscsi-initiator-utils is it?
Comment 5 Mike Christie 2007-10-05 02:32:00 EDT
Ah ignore my comment #44. For F7 and above we are not compiling it as static, so
the patch for this bz https://bugzilla.redhat.com/show_bug.cgi?id=225915 is what
broke it.
Comment 6 Mike Christie 2007-10-05 03:58:06 EDT
This should be fixed in iscsi-initiator-utils-6.2.0.865-0.2.fc8. That should go
up soon. I will send a link to the rpm when it is ready.
Comment 7 Kostas Georgiou 2007-10-05 07:45:13 EDT
Aha I looked at the sources but I missed the static getpwuid. I see that
iscsi-initiator-utils-6.2.0.865-0.2.fc8 has finished building in koji so I'll
try to test it during the weekend.
Comment 8 Lubomir Kundrak 2008-02-09 13:04:32 EST
ISCSI root does work for me now. Does it do also for you?
Comment 9 Kostas Georgiou 2008-02-09 15:19:51 EST
I didn't had the time to test with a recent rawhide :( If the xen kernel is
functional I'll try to give it a go again. Unfortunately I am leaving for
holidays so it might take some time if I don't find the time tomorrow.

Since it's working for you and iscsistart is statically build now I am closing
the bug. 

Note You need to log in before you can comment on or make changes to this bug.