Bug 284051 - Mock exits successfully after failure in case buildtree cannot be removed
Mock exits successfully after failure in case buildtree cannot be removed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-09 11:55 EDT by Jos Vos
Modified: 2013-01-09 20:41 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.8.4-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 15:05:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2007-09-09 11:55:46 EDT
Description of problem:
When mock cannot remove a previous tree, e.g. because of the problem described
in bugzilla #235151, and thus fails to build the package, it still exits with
status 0, as if all was ok.

Version-Release number of selected component (if applicable):
0.7.4-1
Comment 1 Jos Vos 2007-09-09 11:58:58 EDT
Oops, typo, I meant the problem described in bugzilla #235141.
Comment 2 Michael E Brown 2007-10-22 13:41:39 EDT
fixed in mock-0.8.0+

mock will never exit with 0 return code if buildroot removal fails.
Comment 3 Fedora Update System 2007-10-24 03:06:18 EDT
mock-0.8.4-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'
Comment 4 Fedora Update System 2007-10-29 15:05:32 EDT
mock-0.8.4-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-11-06 11:12:03 EST
mock-0.8.4-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mock'
Comment 6 Fedora Update System 2007-11-08 01:01:41 EST
mock-0.8.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.