Bug 284081 - Pidgin crashes all the time
Pidgin crashes all the time
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-09 14:28 EDT by Peter Janakiev
Modified: 2008-03-09 09:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-09 09:01:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Janakiev 2007-09-09 14:28:41 EDT
Description of problem:
Pidgin crashes every few hours no evident reason, usually when changing from one
tab to another.

Version-Release number of selected component (if applicable):

pidgin-2.1.1-1.fc7
libpurple-2.1.1-1.fc7

How reproducible:
Still don;t know how to reproduce, but this is happening a lot


Steps to Reproduce:
1.
2.
3.
  
Actual results:All windows closes, core dumped Segfault 11


Expected results:Normal workflow


Additional info:

Debug info collected from the coredump:


#0  0x00110402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0057bfa0 in raise () from /lib/libc.so.6
No symbol table info available.
#2  0x0057d8b1 in abort () from /lib/libc.so.6
No symbol table info available.
#3  0x080bbabb in sighandler (sig=11) at gtkmain.c:208
No locals.
#4  <signal handler called>
No symbol table info available.
#5  purple_conversation_get_type (conv=0x32008000) at conversation.c:518
        __PRETTY_FUNCTION__ = "purple_conversation_get_type"
#6  0x080838ea in conv_placement_last_created_win_type_configured_cb (
    w=0x9321bf0, event=0x9586550, conv=0x950d978) at gtkconv.c:9052
        x = 188
        y = 96
        type = PURPLE_CONV_TYPE_UNKNOWN
        all = (GList *) 0x95ae3f8
#7  0x00dc4500 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#8  0x001bdda2 in g_closure_invoke () from /lib/libgobject-2.0.so.0
No symbol table info available.
#9  0x001ce4d3 in ?? () from /lib/libgobject-2.0.so.0
No symbol table info available.
#10 0x001cf7bf in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
No symbol table info available.
#11 0x001cfbb9 in g_signal_emit () from /lib/libgobject-2.0.so.0
No symbol table info available.
#12 0x00ed9298 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#13 0x00dbebb9 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#14 0x0015241a in ?? () from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#15 0x008587f2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#16 0x0085b7cf in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#17 0x0085bb79 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#18 0x00dbef44 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#19 0x080bb37a in main (argc=1, argv=0xbfd540c4) at gtkmain.c:883
        display = <value optimized out>
        opt_help = <value optimized out>
        opt_login = 0
        opt_nologin = 0
        opt_version = <value optimized out>
        opt_si = 1
        opt_config_dir_arg = 0x0
        opt_login_arg = 0x0
        opt_session_arg = 0x0
        accounts = (GList *) 0x0
        sig_indx = <value optimized out>
        sigset = {__val = {91143, 0 <repeats 31 times>}}
        prev_sig_disp = <value optimized out>
        errmsg =
"\b\000\000\000,\000\000\000��T\000l<տu\aT\000�\034���\034��\024\000\000\000\000\000\000\000�$�\000\034!տ\000\200��\2308��(\235��\000@��\000\000\000\000_<տX<տT<տ\234\005U\000�\203T\000\034",
'\0' <repeats 11 times>, "��T\000\000\000\000\000�$�\000��T\000\004\000\000\000�
տ�
տ�\204T\000\b\000\000\000$\000\000\000��T\000l<տu\aT\000�\034���\034��\020\000\000\000�m\235\000\230!տ6\034T\000(\235��\000\200��\000@��\000\000\000\000_<տX<տT<տ\234"...
        segfault_message_tmp = <value optimized out>
        error = (GError *) 0x0
        opt = <value optimized out>
        gui_check = <value optimized out>
        debug_enabled = <value optimized out>
        migration_failed = <value optimized out>
        active_accounts = <value optimized out>
        long_options = {{name = 0x80fe8ad "config", has_arg = 1, flag = 0x0, 
    val = 99}, {name = 0x80f04b9 "debug", has_arg = 0, flag = 0x0, val = 100}, 
  {name = 0x80f300a "help", has_arg = 0, flag = 0x0, val = 104}, {
    name = 0x80f075c "login", has_arg = 2, flag = 0x0, val = 108}, {
    name = 0x80fb460 "multiple", has_arg = 0, flag = 0x0, val = 109}, {
    name = 0x80fb469 "nologin", has_arg = 0, flag = 0x0, val = 110}, {
    name = 0x80fe8a3 "session", has_arg = 1, flag = 0x0, val = 115}, {
    name = 0x80f454b "version", has_arg = 0, flag = 0x0, val = 118}, {
    name = 0x0, has_arg = 0, flag = 0x0, val = 0}}


I am not sure if I have the needed debug packages, I installed the pigdin debug
only.
Comment 1 Peter Janakiev 2007-09-10 17:20:32 EDT
Sorry, I guess this is the correct backtrace:

Thread 2 (process 8569):
#0  0x00110402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00619a43 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x0085b803 in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#3  0x0085bb79 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00aa15d4 in ?? () from /usr/lib/libnm_glib.so.0
No symbol table info available.
#5  0x0087666f in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#6  0x006f544b in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x0062380e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (process 8568):
#0  0x00110402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0057bfa0 in raise () from /lib/libc.so.6
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#2  0x0057d8b1 in abort () from /lib/libc.so.6
No symbol table info available.
#3  0x080bbabb in sighandler (sig=11) at gtkmain.c:208
No locals.
#4  <signal handler called>
No symbol table info available.
#5  purple_conversation_get_type (conv=0x32008000) at conversation.c:518
        __PRETTY_FUNCTION__ = "purple_conversation_get_type"
#6  0x080838ea in conv_placement_last_created_win_type_configured_cb (
    w=0x9321bf0, event=0x9586550, conv=0x950d978) at gtkconv.c:9052
        x = 188
        y = 96
        type = PURPLE_CONV_TYPE_UNKNOWN
        all = (GList *) 0x95ae3f8
#7  0x00dc4500 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#8  0x001bdda2 in g_closure_invoke () from /lib/libgobject-2.0.so.0
No symbol table info available.
#9  0x001ce4d3 in ?? () from /lib/libgobject-2.0.so.0
No symbol table info available.
#10 0x001cf7bf in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#11 0x001cfbb9 in g_signal_emit () from /lib/libgobject-2.0.so.0
No symbol table info available.
#12 0x00ed9298 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#13 0x00dbebb9 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#14 0x0015241a in ?? () from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#15 0x008587f2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
No symbol table info available.
#16 0x0085b7cf in ?? () from /lib/libglib-2.0.so.0
No symbol table info available.
#17 0x0085bb79 in g_main_loop_run () from /lib/libglib-2.0.so.0
No symbol table info available.
#18 0x00dbef44 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#19 0x080bb37a in main (argc=1, argv=0xbfd540c4) at gtkmain.c:883
        display = <value optimized out>
        opt_help = <value optimized out>
        opt_login = 0
        opt_nologin = 0
        opt_version = <value optimized out>
        opt_si = 1
---Type <return> to continue, or q <return> to quit---
        opt_config_dir_arg = 0x0
        opt_login_arg = 0x0
        opt_session_arg = 0x0
        accounts = (GList *) 0x0
        sig_indx = <value optimized out>
        sigset = {__val = {91143, 0 <repeats 31 times>}}
        prev_sig_disp = <value optimized out>
        errmsg =
"\b\000\000\000,\000\000\000��T\000l<տu\aT\000�\034���\034��\024\000\000\000\000\000\000\000�$�\000\034!տ\000\200��\2308��(\235��\000@��\000\000\000\000_<տX<տT<տ\234\005U\000�\203T\000\034",
'\0' <repeats 11 times>, "��T\000\000\000\000\000�$�\000��T\000\004\000\000\000�
տ�
տ�\204T\000\b\000\000\000$\000\000\000��T\000l<տu\aT\000�\034���\034��\020\000\000\000�m\235\000\230!տ6\034T\000(\235��\000\200��\000@��\000\000\000\000_<տX<տT<տ\234"...
        segfault_message_tmp = <value optimized out>
        error = (GError *) 0x0
        opt = <value optimized out>
        gui_check = <value optimized out>
        debug_enabled = <value optimized out>
        migration_failed = <value optimized out>
        active_accounts = <value optimized out>
        long_options = {{name = 0x80fe8ad "config", has_arg = 1, flag = 0x0, 
    val = 99}, {name = 0x80f04b9 "debug", has_arg = 0, flag = 0x0, val = 100}, 
  {name = 0x80f300a "help", has_arg = 0, flag = 0x0, val = 104}, {
---Type <return> to continue, or q <return> to quit---
    name = 0x80f075c "login", has_arg = 2, flag = 0x0, val = 108}, {
    name = 0x80fb460 "multiple", has_arg = 0, flag = 0x0, val = 109}, {
    name = 0x80fb469 "nologin", has_arg = 0, flag = 0x0, val = 110}, {
    name = 0x80fe8a3 "session", has_arg = 1, flag = 0x0, val = 115}, {
    name = 0x80f454b "version", has_arg = 0, flag = 0x0, val = 118}, {
    name = 0x0, has_arg = 0, flag = 0x0, val = 0}}


Comment 2 Kyrre Ness Sjøbæk 2007-12-30 11:32:56 EST
I'm unshure, but i'm experiencing that pidgin freezes quite often (every 5-10
minutes with heavy use) on FC8, as you say, when switching tabs (most often).

pidgin-2.3.1-1.fc8
libpurple-2.3.1-1.fc8
Comment 3 Stu Tomlinson 2008-03-08 15:27:37 EST
Peter, if this is still happening, please install the debuginfo packages (using
"debuginfo-install pidgin") and get a new backtrace as described on
http://fedoraproject.org/wiki/StackTraces
Comment 4 Peter Janakiev 2008-03-09 05:54:55 EDT
No, it was caused by something in my contacts, I have deleted ost of them
(mostly old ones i dont use anymore) and now it works perfectly fine. Maybe
something with the char codes of the groups as sent by the servers. I dont know
didnt had the time go dig for this

Note You need to log in before you can comment on or make changes to this bug.