Bug 284111 - Network-card keeps its "tmp__xxxx" sysfs name instead of an ethx name, after /sbin/start_udev has finished.
Network-card keeps its "tmp__xxxx" sysfs name instead of an ethx name, after ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-09 15:31 EDT by Bjoern Rasmussen
Modified: 2014-03-16 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 21:58:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is for the ethernet nic: ifcfg-eth0 (213 bytes, text/plain)
2007-09-12 14:22 EDT, Bjoern Rasmussen
no flags Details
... and this is for the wlan pccard adapter: ifcfg-eth1. (304 bytes, text/plain)
2007-09-12 14:24 EDT, Bjoern Rasmussen
no flags Details

  None (edit)
Description Bjoern Rasmussen 2007-09-09 15:31:36 EDT
Description of problem:

Network-card keeps its "tmp__xxxx" sysfs name instead of an ethx name, after
/sbin/start_udev has finished.  The card is consequently not set up by the
networking-scripts, which looks for ethx.

Unloading and loading the module (prism54) for the card, resolves the problem. 
The card is an Intersil 3890 based wireless card, which requires loading of
firmware.

The bug #210780 should probably be marked a duplicate to this one.


Version-Release number of selected component (if applicable):

udev-113-11.fc7


How reproducible:

Problem occures nearly each boot.  Reloading the module afterwards always work
as a fix.


Steps to Reproduce:

1. Boot to runlevel 1.
2. "iwconfig" does not show ethx, but __tmpxxx...
3. modprobe -r prism54 followed by modprobe prisme54 fixes the problem.
  

Actual results:

Network-card not brought up by the networking-scripts.


Expected results:

It shouldn't be necessary to reload the module to bring up the card.


Additional info:

Bug #210780 might pinpoint the problem (timing).
Comment 1 Bill Nottingham 2007-09-10 13:52:04 EDT
Is the kudzu init script active? Do you have a config file for this interface?
Comment 2 Bjoern Rasmussen 2007-09-11 14:19:10 EDT
Yes to both questions.

But the module for the card is loaded when runlevel 1 is reached, so why bother?
 Kudzu and networking scripts run at level 3.
Comment 3 Bill Nottingham 2007-09-11 14:39:19 EDT
What do your config files look like?

The fact that it's named __tmp* implies that it needed to be renamed so that
another interface could be configured correctly.
Comment 4 Bjoern Rasmussen 2007-09-12 14:18:32 EDT
Ok, so it's not an error that interfaces get __tmp-names occasionally after
runlevel 1 is reached?  Well, then I was assuming to much here.  Sorry.

I'll create a couple of attachments for my config files:
Comment 5 Bjoern Rasmussen 2007-09-12 14:22:25 EDT
Created attachment 193731 [details]
This is for the ethernet nic: ifcfg-eth0
Comment 6 Bjoern Rasmussen 2007-09-12 14:24:28 EDT
Created attachment 193741 [details]
... and this is for the wlan pccard adapter: ifcfg-eth1.
Comment 7 Bjoern Rasmussen 2007-09-12 14:30:37 EDT
Comment on attachment 193731 [details]
This is for the ethernet nic: ifcfg-eth0

# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IPV6INIT=no
ONBOOT=no
USERCTL=no
PEERDNS=yes
TYPE=Ethernet
DEVICE=eth0
HWADDR=xxxxxxxxxxxx ...
BOOTPROTO=dhcp
Comment 8 Bjoern Rasmussen 2007-09-12 14:32:07 EDT
Comment on attachment 193731 [details]
This is for the ethernet nic: ifcfg-eth0
Comment 9 Bjoern Rasmussen 2007-09-12 14:33:06 EDT
Please disregard #7 and #8!
Comment 10 Bjoern Rasmussen 2008-01-28 16:48:32 EST
Looks like this problem is fixed in Fedora 8.  It works fine for me now (uname
-a output: "Linux host.domain 2.6.23.14-107.fc8 #1 SMP Mon Jan 14 21:37:30 EST
2008 i686 athlon i386 GNU/Linux"
Comment 11 Bill Nottingham 2008-01-28 21:58:36 EST
Correct, Fedora 8 does this differently (using udev rules) to avoid the issue.
Sorry about the delay.
Comment 12 Bjoern Rasmussen 2008-01-29 14:28:38 EST
No problem!  It was not a big issue for me, but I'm glad to see things are
getting better :-)

Note You need to log in before you can comment on or make changes to this bug.