Bug 284181 - rsync does not work at all
rsync does not work at all
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-09 18:10 EDT by John Poelstra
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 10:45:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of rsync failure (10.44 KB, text/plain)
2007-09-09 18:10 EDT, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2007-09-09 18:10:11 EDT
Description of problem:
rsync does not work locally or from remote box to local box

Version-Release number of selected component (if applicable):
Installed F8T2 and then yum updated to latest rsync
rsync-2.6.9-3.1.fc8

How reproducible:
Every time

Steps to Reproduce:
1. attempt to rsync a directory or files
2.
3.
 

Additional info:
see attached strace
Comment 1 John Poelstra 2007-09-09 18:10:11 EDT
Created attachment 191161 [details]
strace of rsync failure
Comment 2 John Poelstra 2007-09-09 18:13:08 EDT
It worked fine in F8T1
Comment 3 Simo Sorce 2007-09-09 20:30:48 EDT
John all I can see is a bunch of Permission Denied errors.
Does it crash, or does it just exit?
Comment 4 Jeremy Katz 2007-09-09 21:30:33 EDT
Looks like this is an SELinux policy problem.  Updating to
selinux-policy-targeted-3.0.7-7.fc8 makes rsync start working for me again.

John, does this help you? 
Comment 5 John Poelstra 2007-09-10 01:43:36 EDT
Simo, it doesn't do anything... you enter the command, hit return, get a
prompt... no crash or error message.  

I would have expected SETroubleshoot to pop up with an error... nothing in
/var/log/messages either.  I'll try the latest selinux-policy and report back.
Comment 6 John Poelstra 2007-09-10 02:12:28 EDT
confirmed--new policy fixes the problem.  I should have looked in audit.log,
there were AVC errors there.  It still looks like setroubleshoot is not doing
its job, but that is for a different bug once I have time to look into it.

Changing component to selinux-policy.  I'm guessing this bug can be closed, but
I'll leave for Dan W to confirm

Note You need to log in before you can comment on or make changes to this bug.