Bug 28428 - i810 Audio not detected during install.
i810 Audio not detected during install.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-20 08:58 EST by Dan Taylor
Modified: 2014-03-16 22:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 10:08:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Taylor 2001-02-20 08:58:22 EST
Dell WS330, WS220, Optiplex GX150, 8100.  During initial install (booting 
from cd), the i810 is not setup.  After the system reboots, kudzu detects 
it & installs it.  In addition, if sndconfig --quiet is run in the post of 
the ks.cfg the audio is still NOT setup until the first boot of the 
system.
Comment 1 Bill Nottingham 2001-02-20 11:53:43 EST
Hm, can't reproduce this here; I did an install, and the PCI sound
card was configured properly in the installer  %post.

What kernel do you have on your boot disk, and what kernel packages
are you installing?
Comment 2 Dan Taylor 2001-02-20 12:09:54 EST
This is happening from the boot kernel on the cd as well as 2.4.1-0.1.9 on a 
hard drive install.  Please note this is not a sound card.  It is the 
integrated i810 audio.
Comment 3 Bill Nottingham 2001-02-20 12:12:23 EST
onboard chip/add-in card distinction is irrelevant; they're all PCI devices as
far as kudzu is concerned.

What kernels are you installing (specifically, are you installing
*only* a SMP or enterprise kernel?)
Comment 4 Dan Taylor 2001-02-20 15:23:22 EST
This is definitely happening on a UP kernel.  I am currently verifying on SMP & 
enterprise kernels.  Will update in the morning.
Comment 5 Bill Nottingham 2001-02-20 15:51:38 EST
No, I was mainly concerned about the case where you don't install
any UP kernels.

If you do a CD-ROM install, is the networking set up?

What does the /etc/sysconfig/hwconf that's there *before* kudzu
runs on reboot look like?
Comment 6 Dan Taylor 2001-02-21 09:35:00 EST
Yes networking is setup.  Here is the hwconf entry for the audio before kudzu:
-
class: AUDIO
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corporation|unknown device 8086:2445"
vendorId: 8086
deviceId: 2445
subVendorId: 1028
subDeviceId: 00d2
pciType: 1
-
and after kudzu:
-
class: AUDIO
bus: PCI
detached: 0
driver: i810_audio
desc: "Unknown vendor|Generic i810_audio device"
vendorId: 8086
deviceId: 2445
subVendorId: 1028
subDeviceId: 00d2
pciType: 1
-

If you want the complete hwconf or lspci -v, let me know & I can attach.
Comment 7 Glen Foster 2001-02-21 10:08:52 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 8 Bill Nottingham 2001-02-21 12:30:16 EST
Hey, it's a new PCI id. That explains it.

kudzu picks it up on boot because it looks at the modules.pcimap file.

Will be fixed in kudzu-0.96.11-1.
Comment 9 Bill Nottingham 2001-02-21 12:32:34 EST
Do you need the ftsodell option for this?
Comment 10 Dan Taylor 2001-02-21 12:43:24 EST
Yes
Comment 11 Bill Nottingham 2001-02-21 12:47:05 EST
<goes and looks>

Actually, once kudzu works, that should get picked up automatically.
Comment 12 Dan Taylor 2001-02-21 13:14:22 EST
I was able to reproduce on Dimension 4100.  This is the hwconf data from the 
Dimension 4100 after kudzu.  There was no listing for audio in the hwconf prior 
to kudzu.  Of additional note, the ftsodell option does not fix the 4100.  I 
will update bug# 23334 to reflect this as we are tracking this separately.
-
class: AUDIO
bus: PCI
detached: 0
driver: i810_audio
desc: "Unknown vendor|Generic i810_audio device"
vendorId: 8086
deviceId: 2445
subVendorId: 8086
subDeviceId: 4541
pciType: 1
-
Comment 13 Dan Taylor 2001-02-21 13:22:06 EST
make that bug# 24731

Note You need to log in before you can comment on or make changes to this bug.