Bug 284461 - RHEL 5: lshal command throws errors
RHEL 5: lshal command throws errors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
5.1
All Linux
medium Severity low
: ---
: ---
Assigned To: David Zeuthen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 07:19 EDT by Dilpreet Gulati
Modified: 2013-03-05 22:51 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0476
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:30:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dilpreet Gulati 2007-09-10 07:19:41 EDT
Description of problem:
lshal command when issued on a RHEL 5 system, errors out on the screen.
The following is the error message " process id : Applications must not close 
shared connections - see dbus_connection_close() docs."

Version-Release number of selected component (if applicable):
hal:
Version:0.5.8.1
Release:19.el5

How reproducible:
Always

Steps to Reproduce:
1. At the console, type lshal
2. The error is seen at the end of the output
3.
  
Actual results:
At the end of the output, error message is thrown:
" process id : Applications must not close shared connections - see 
dbus_connection_close() docs."


Expected results:
No error messages should be seen

Additional info:

This issue is fixed in the hal-0.5.9-8.fc7
Comment 1 RHEL Product and Program Management 2007-10-15 23:41:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 John (J5) Palmieri 2007-10-16 12:46:00 EDT
This is a harmless warning with an easy fix (just patch the close call out). 
The D-Bus call simply ignores close requests on shared connections since the
library and not the application manages shared connection.  In later versions of
D-Bus we added the warning so developers would fix their code otherwise it is
just a no-op.

Kicking to davidz who owns HAL.
Comment 4 David Zeuthen 2008-01-02 14:10:47 EST
* Wed Jan 02 2008 David Zeuthen <davidz@redhat.com> - 0.5.8.1-28%{?dist}
- Silence errors with lshal
- Resolves: #284461
Comment 8 errata-xmlrpc 2008-05-21 13:30:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0476.html

Note You need to log in before you can comment on or make changes to this bug.