Bug 2846 - installer still broken for hard drive installs.
installer still broken for hard drive installs.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-15 17:55 EDT by jrm
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-15 18:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jrm 1999-05-15 17:55:07 EDT
I entered a new bug last week regarding how the installer
was broken in two different ways when doing a hard drive
install.  I also commented on someone else's problem with
their hard drive install, saying that it was similiar to the
problem I had.  My first bug report was closed, being called
a duplicate of the other report (2506).  That report was
subsequently closed, saying reopen if it is really broken.
Unfortunately, I don't appear to be able to reopen that bug
(or I can't find that option easily in bugzilla, possibly
because I didn't submit that one).  There is no boot.img
mentioned in the Errata, so both of the problems I
encountered still exist in the current set of disks.

Here are brief descriptions of the two problems:

1.  Can not upgrade the root partition if it is the
partition containing the install files, fails with an RPM
database not found message after mistakengly unmounting the
root.

2.  Can not upgrade the root partition if another partition
contains the install files, if that partition is mentioned
in the /etc/fstab.  This causes some strange symlink problem
 having to do with /tmp/hdimage to appear.

I consider these bugs severe since most likely the root
partition someone is upgrading either contains the install
files, or the partition that contains them is going to be in
the /etc/fstab.  This means most hard drive based upgrades
will fail.

Feel free to email me for further info...
Comment 1 Jeff Johnson 1999-05-15 18:14:59 EDT
*** This bug has been marked as a duplicate of 2506 ***

Note You need to log in before you can comment on or make changes to this bug.