Bug 284711 - perl: /usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-multi/auto/DBD/mysql/mysql.so: undefined symbol: DBIc_TRACE_LEVEL
perl: /usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-multi/auto/DBD/mysql/...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: perl-DBD-MySQL (Show other bugs)
4.6
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 11:47 EDT by John Barker
Modified: 2008-09-02 03:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-02 03:19:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Barker 2007-09-10 11:47:15 EDT
From Bugzilla Helper:
User-Agent: Opera/9.23 (X11; Linux i686; U; en)

Description of problem:
When running any perl script that uses DBI mySQL the follorinw error is produced

./dbd_test_case.pl

/usr/bin/perl: symbol lookup error: /usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-
thread-multi/auto/DBD/mysql/mysql.so: undefined symbol: DBIc_TRACE_LEVEL

Version-Release number of selected component (if applicable):
perl-DBD-MySQL-4.005-1, mysql-4.1.20-2

How reproducible:
Always


Steps to Reproduce:
1.
Create a script called dbd_test_case.pl with the following:
#!/usr/bin/perl -W
use strict;
use warnings;
use DBI;
my $dsn = "DBI:mysql:database=test;host=localhost;port=3306";

my 	$dbh = DBI->connect($dsn, 'test', 'test', {RaiseError => 1}) or 
log_to_error_file("connect with $dsn Error: $DBI::errstr");


2.
perl dbd_test_case.pl
perl: symbol lookup error: /usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-
multi/auto/DBD/mysql/mysql.so: undefined symbol: DBIc_TRACE_LEVEL


Actual Results:
perl: symbol lookup error: /usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-
multi/auto/DBD/mysql/mysql.so: undefined symbol: DBIc_TRACE_LEVEL

Expected Results:
The above error should not occur

Additional info:
rpm -qif /usr/bin/mysql
Name        : mysql                        Relocations: (not relocatable)
Version     : 4.1.20                            Vendor: Red Hat, Inc.
Release     : 2.RHEL4.1.0.1                 Build Date: Tue 28 Aug 2007 
20:34:12 BST
Install Date: Fri 07 Sep 2007 15:43:22 BST      Build Host: js20-bc1-
9.build.redhat.com
Group       : Applications/Databases        Source RPM: mysql-4.1.20-
2.RHEL4.1.0.1.src.rpm
Size        : 6084109                          License: GPL
Signature   : DSA/SHA1, Wed 29 Aug 2007 13:46:33 BST, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.mysql.com
Summary     : MySQL client programs and shared library.
Description :
MySQL is a multi-user, multi-threaded SQL database server. MySQL is a
client/server implementation consisting of a server daemon (mysqld)
and many different client programs and libraries. This package
contains the MySQL client programs, the client shared library, and
generic MySQL files.
Name        : mysql                        Relocations: (not relocatable)
Version     : 4.1.20                            Vendor: Red Hat, Inc.
Release     : 2.RHEL4.1.0.1                 Build Date: Tue 28 Aug 2007 
20:19:59 BST
Install Date: Fri 07 Sep 2007 15:43:42 BST      Build Host: js20-bc1-
11.build.redhat.com
Group       : Applications/Databases        Source RPM: mysql-4.1.20-
2.RHEL4.1.0.1.src.rpm
Size        : 5686211                          License: GPL
Signature   : DSA/SHA1, Wed 29 Aug 2007 13:46:37 BST, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.mysql.com
Summary     : MySQL client programs and shared library.
Description :
MySQL is a multi-user, multi-threaded SQL database server. MySQL is a
client/server implementation consisting of a server daemon (mysqld)
and many different client programs and libraries. This package
contains the MySQL client programs, the client shared library, and
generic MySQL files.

rpm -qif /usr/lib/perl5/vendor_perl/5.8.5/ppc-linux-thread-multi/auto/DBD/mysql/
mysql.so
Name        : perl-DBD-MySQL               Relocations: (not relocatable)
Version     : 4.005                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Wed 08 Aug 2007 
21:42:52 BST
Install Date: Wed 05 Sep 2007 15:20:10 BST      Build Host: js20-bc2-
10.build.redhat.com
Group       : Development/Languages         Source RPM: perl-DBD-MySQL-4.005-
1.src.rpm
Size        : 333654                           License: GPL or Artistic
Signature   : DSA/SHA1, Fri 10 Aug 2007 21:19:08 BST, Key ID fd372689897da07a
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://search.cpan.org/dist/DBD-mysql/
Summary     : An implementation of DBI for MySQL.
Description :
A MySQL interface for Perl.
Comment 1 David Nutter 2007-09-19 07:37:39 EDT
This problem also occurs on RHEL4u6 ES x86_64, as shown below:

[davidn@kes ~] $  perl -MDBI -e
'$db=DBI->connect("DBI:mysql:test:localhost","test","test") or die("Cannot
connect: $DBI::errstr");'

perl: symbol lookup error:
/usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi/auto/DBD/mysql/mysql.so:
undefined symbol: DBIc_TRACE_LEVEL
Comment 2 Robin Norwood 2007-11-02 15:30:31 EDT
Unfortunately, perl-DBD-MySQL-4.005 is not ABI compatible with older versions as
I first thought.  we probably will not be able to release 4.005 as an update for
RHEL4.
Comment 3 Marcela Mašláňová 2008-09-02 03:19:40 EDT
I'm sorry but I see as the latest release for RHEL-4 perl-DBD-MySQL-2.9004-3.1 We decided not to ship perl-DBD-MySQL-4.005, because of ABI breakage. Please downgrade back on the proper version.

Note You need to log in before you can comment on or make changes to this bug.