Bug 2849 - Tcl/Tk is not properly localized
Tcl/Tk is not properly localized
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: 965 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 1999-05-16 00:37 EDT by Aleksey Nogin
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-04 22:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The updated SPEC file. (14.48 KB, text/plain)
1999-12-05 18:11 EST, Aleksey Nogin
no flags Details
Updated expect-*-alpha.patch (814 bytes, patch)
1999-12-05 18:12 EST, Aleksey Nogin
no flags Details | Diff
Updated expect-*-jbj.patch (404 bytes, patch)
1999-12-05 18:12 EST, Aleksey Nogin
no flags Details | Diff
Updated tclX-*-jbj.patch (775 bytes, patch)
1999-12-05 18:13 EST, Aleksey Nogin
no flags Details | Diff
A new patch to make sure that Tix is linked agains the correct version of Tcl/Tk (56.27 KB, patch)
1999-12-05 18:14 EST, Aleksey Nogin
no flags Details | Diff

  None (edit)
Description Aleksey Nogin 1999-05-16 00:37:56 EDT
Tcl/Tk is not properly localized. As a result, Tk programs
(such as ical) do not allow to input non-ASCII characters on
a properly localized X11 system.

I do not have access to RH 6.0 system yet, but from looking
at source RPM I got the impression that it is not fixed yet.

There is a patch that is supposed to fix this and other
locale problems in Tcl at
. I have not tested it yet.
Comment 1 Jeff Johnson 1999-05-16 11:25:59 EDT
What version of tcl? Could you verify that the Raw Hide tcltk-8.0.5 is
still not localized correctly? How about tcl8.1?
Comment 2 Jeff Johnson 1999-05-16 19:46:59 EDT
*** Bug 965 has been marked as a duplicate of this bug. ***

When while typing in a description of a new item I switch
keyboard into the Cyrillic mode (I am using Xkb, it
generates Cyrillic_* keysyms and I am using ru_RU.KOI8-R
locale) and start typing, ical would not react (as if
nothing is typed).

When xterm, Netscape or gvim is started from the same shell,
cyrillics works fine.

I checked it with the following setup:


P.S. rxvt and nxterm have the same problem (bug reports
Comment 3 Aleksey Nogin 1999-05-28 00:04:59 EDT
I looked at the tcltk-8.0.5-30.src.rpm, it does not seem to be
Comment 4 Jeff Johnson 1999-09-02 12:44:59 EDT
I will either add these changes the next time I rebuild tcl or
I will rebuild the tcl-8.2 packages. Sorry for the delay ...
Comment 5 Aleksey Nogin 1999-11-07 18:17:59 EST
RedHat 6.1 and current rawhide still have the same tcl-8.0.5-30
Comment 6 Aleksey Nogin 1999-12-05 18:10:59 EST
In an attempt to help you to compile tcl/tk 8.2 for Rawhide:

I took tcltk-8.0.5-30 SRPM and upgraded to tcl/tk 8.2.2, expect 5.31.2, tclX
8.1.1 (and alos added and updated some URLs)... I've fixed everything in the
package to make sure that everything compiles correctlly and that each package
inside was compiled and linked against tcl/tk 8.2 instead of tcl/tk 8.05 that
was installed on the system during the build. However I have not yet checked if
anything actually runs...

I've uploaded the result of my work to contrib.redhat.com. I am also going to
attach all updated files (.spec and .patch) to this bug report.
Comment 7 Aleksey Nogin 1999-12-05 18:11:59 EST
Created attachment 24 [details]
The updated SPEC file.
Comment 8 Aleksey Nogin 1999-12-05 18:12:59 EST
Created attachment 25 [details]
Updated expect-*-alpha.patch
Comment 9 Aleksey Nogin 1999-12-05 18:13:59 EST
Created attachment 27 [details]
Updated tclX-*-jbj.patch
Comment 10 Aleksey Nogin 1999-12-05 18:14:59 EST
Created attachment 28 [details]
A new patch to make sure that Tix is linked agains the correct version of Tcl/Tk
Comment 11 Aleksey Nogin 1999-12-06 16:19:59 EST
I tried to install my Tcl/Tk RPMs, to compile ical against them and to run ical.
Still problems with localization, some things even became worse...

1) It ignores Cyrillic_* keysyms (same as with 8.0.5)
2) It believes that all my appointments are in ISO-8859-1. Previously I could
force ical to show them in correct (KOI8-R) font, but Tk 8.2 is too smart and
uses ISO-8859-1 font.

End result - with unpatched 8.0.5 I could read, but not write, with patched
8.0.5 I could do both, but with 8.2.2 I can do neither.
Comment 12 Aleksey Nogin 1999-12-06 16:23:59 EST
BTW, the updated URL for the 8.0.4 patch is
Comment 13 Jeff Johnson 2000-03-18 16:11:59 EST
I've just rebuilt tcltk-8.2.3-36, although I suspect that nothing
has changed wrto localization from your attempts. Thanks for the patches.
Comment 14 Jeff Johnson 2000-06-03 10:07:55 EDT
I just packaged tcl-8.3.1 in Raw Hide, hopefiully that should be (finally!)
localized. If not, reopen this bug, and I'll try Yet Again. Thanks for the
Comment 15 Aleksey Nogin 2001-04-22 12:06:06 EDT
Just tried it is 7.1 and couldn't enter Cyrillic messages in Ical.
Comment 16 Jens Petersen 2002-08-07 07:27:31 EDT
Well XIM certainly doesn't work in tcktk-8.3 at least.
If we want to revisit this, the bug can be re-opened.

Note You need to log in before you can comment on or make changes to this bug.