Bug 284981 - 201124: update irqbalance package from upstream (v0.55)
201124: update irqbalance package from upstream (v0.55)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: irqbalance (Show other bugs)
5.2
other All
medium Severity high
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks: 227737
  Show dependency treegraph
 
Reported: 2007-09-10 15:00 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.55-6.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 15:19:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 38647 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-09-10 15:00:23 EDT
=Comment: #0=================================================
Stephanie A. Glass <sglass&#64;us.ibm.com> - 2007-09-10 14:57 EDT
1. Feature Id:	201124
Feature Name: 	update irqbalance package from upstream (v0.55)
Sponsor: 	LTC
Category: 	xSeries
Request Type: 	Package - Update Version

2. Short Description: 	The latest version of the irqbalance package includes
NUMA awareness and our high end System x systems are now exporting additional
BIOS information which enables this irqbalance code to make better decisions on
IRQ affinity for this hardware. The result is improved performance. This version
of the package appears to be in the open/upstream non-enterprise distro release
already.
Architecture 	x86 	x86_64
Architecture Specific ? Purely Common Code
Affects Toolchain ? no	
Affects Installer ? no	
Affects Desktop ? no	
Affects Core Kernel (not mod)? 	no
Affects Kernel Module ?  no
	
3. Describe the Business Case:	Improved performance enhances the image of linux
as capable in a high end space previously dominated by proprietary operating
systems, opening the door for new/additional license revenue.
Performance Assistance Required?: 	yes
Benefits: 	Hardware enablement & Performance
	
4. Sponsor Priority: 	1
IBM Confidential: 	no
Code Contribution ?: 	
Upstream Acceptance: 	Accepted
Component Release Version Target: 	irqbalance-0.55

Delivery Mechanism 	Direct from community

5. Hardware to Red Hat: Already available on site

6. Pm Contact: Mike Wortman, wortman@us.ibm.com, 512-838-8582

7. Technical Contact: Vaidyanathan Srinivasan, svaidyan@in.ibm.com, Bangalore
91-80-41777174
Comment 1 Neil Horman 2007-09-10 15:19:44 EDT
This is already slated to happen in RHEL5.1
Comment 2 IBM Bug Proxy 2007-09-10 16:00:30 EDT
------- Comment From sglass@us.ibm.com 2007-09-10 15:57 EDT-------
Red Hat says that this will be in RHEL 5.1.  Please check the snap we get this
week, if it isn't in that, please let me know and I ping Red Hat on this.

If it is in in, please close both the feature bug and devtrack.

Thanks

Stephanie
Comment 3 IBM Bug Proxy 2007-09-14 15:30:32 EDT
------- Comment From svaidyan@in.ibm.com 2007-09-14 15:27 EDT-------
irqbalance daemon 0.55 is included in RHEL 5.1 snapshot 4
I have functionally verified irqbalance 0.55 behaviour on 5.1 snap4 and snap6

However there are few minor issues in the integration:

1. In /etc/init.d/irqbalance service script

>> daemon irqbalance $ONESHOT $IRQ_AFFINITY

The second parameter $IRQ_AFFINITY is not assigned and is not used by the
application.  It should be removed since the MASK is already passed as
IRQBALANCE_BANNED_CPUS

2. In /etc/sysconfig/irqbalance

The comment for IRQ_AFFINITY_MASK is incorrect

#    64 bit bitmask which allows you to indicate which cpu's should
#    be skipped when reblancing irqs.  Cpu numbers which have their
#    corresponding bits set to zero in this mask will not have any
^^^^ one
#    irq's assigned to them on rebalance

It would be better if this variable is changed to IRQBALANCE_BANNED_CPUS
and directly passed to irqbalance daemon in /etc/init.d/irqbalance

3. New entry for IRQBALANCE_BANNED_INTERRUPTS in /etc/sysconfig/irqbalance

This version of the daemon supports interrupt blacklisting as well.  Hence this
variable should also be added with description in /etc/sysconfig/irqbalance
Comment 4 IBM Bug Proxy 2007-10-15 03:55:25 EDT
------- Comment From svaidyan@in.ibm.com 2007-10-15 03:53 EDT-------
As per RH suggestion, 3 bugs have been opened for these three issues:

39650: irqbalance daemon: IRQBALANCE_BANNED_CPUS mask
39651: irqbalance daemon: IRQ_AFFINITY_MASK
39652: irqbalance daemon: IRQBALANCE_BANNED_INTERRUPTS

These are minor integrations issues with the new version of irqbalance daemon.

These bugs have been marked dependent just for grouping them.  Technically
they can be independently solved.

This bug 38647 can be closed since this has been broken down into the above
mentioned 3 new bugs.

Thanks,
Vaidy
Comment 5 IBM Bug Proxy 2007-10-26 08:41:11 EDT
------- Comment From sglass@us.ibm.com 2007-10-26 08:36 EDT-------
Since we opened the bugs on the remaining issues,  I am closing this feature
request

Note You need to log in before you can comment on or make changes to this bug.