Bug 28507 - up2date system upgrade did not upgrade lilo.conf
Summary: up2date system upgrade did not upgrade lilo.conf
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-20 21:38 UTC by Joshua Buysse
Modified: 2015-01-07 23:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 21:38:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Buysse 2001-02-20 21:38:52 UTC
I did a system upgrade from fisher through up2date, following instructions
sent to testers-list, and was left with a non-bootable system.  

Up2date upgraded the kernel (and many other things, only left out xemacs
and netscape* due to disk space limitations in /var).  Lilo.conf was left
with a stale reference to a vmlinuz-2.4.0-0.99.11 that did not exist
anymore, and I got the wonderfully insightful error message "LI" at boot. :)

There's no mention of any failures in the up2date log, but I can forward
that along if it's requested.

Comment 1 Jay Turner 2001-02-20 23:04:13 UTC
The kernel is included in the up2date skip list for a reason.  Taking the
package out of the skip list without understanding the implications and then
blowing away a machine is not a bug.  We are in the process of making the kernel
upgrade process less painful, but for the moment, up2date did exactly what you
told it to do and exactly what it would do if you ran 'rpm -ihv' from the
command line.


Note You need to log in before you can comment on or make changes to this bug.