Bug 28539 - getty_ps dumps core after entering login when using /etc/conf.getty
Summary: getty_ps dumps core after entering login when using /etc/conf.getty
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: getty_ps (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-21 06:28 UTC by Andy Payne
Modified: 2014-03-17 02:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 19:30:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Payne 2001-02-21 06:28:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18 i586; Nav)


when using the /etc/conf.getty file for changing getty_ps defaults,
getty_ps crases after entering your login.

Reproducible: Always
Steps to Reproduce:
1. create an /etc/conf.getty
2. setup a serial terminal/minicom on another machine - configure
/etc/inittab something like this:
--
s1:2345:respawn:/sbin/getty ttyS1 DT38400 vt100
--
3. attempt to login
	

Actual Results:  getty_ps respawns and you
end up with an entry like this in your /var/log/messages:
--
Feb 20 22:05:11 hostname getty[29924]: Segmentation fault
--

Expected Results:  should have received a Password: prompt

using a home brew 2.2.18 kernel. problem was producable right out of the
box however. all the latest updates are installed.

Comment 1 Bill Nottingham 2001-02-21 17:19:37 UTC
What does your /etc/conf.getty look like?

Comment 2 Andy Payne 2001-02-21 19:30:13 UTC
the contents of conf.getty make no difference... dumps core no matter what the
contents are.
here is the current contents of /etc/conf.getty
--
VERSION=2.2.18
--

Comment 3 Bill Nottingham 2001-02-21 19:50:05 UTC
I can't reproduce this here on the current beta, running both that version
of getty_ps, and the version that shipped in 7.0.


Note You need to log in before you can comment on or make changes to this bug.