Bug 285511 - Pulseaudio does not start up properly
Pulseaudio does not start up properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 21:15 EDT by Dennis Jacobfeuerborn
Modified: 2008-03-28 15:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 15:50:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2007-09-10 21:15:30 EDT
Pulseaudio is not usable after boot and outputs the following in the syslog:

Sep  9 02:59:57 nexus pulseaudio[2966]: alsa-util.c: Cannot find mixer control
"Master".
Sep  9 02:59:57 nexus pulseaudio[2966]: alsa-util.c: Cannot find fallback mixer
control "PCM".
Sep  9 02:59:57 nexus pulseaudio[2966]: module-alsa-sink.c: Failed to set
hardware parameters: Operation not permitted
Sep  9 02:59:57 nexus pulseaudio[2966]: module.c: Failed to load  module
"module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_1412_1712_alsa_playback_0"): initialization failed.
Sep  9 02:59:57 nexus pulseaudio[2966]: module-alsa-source.c: Failed to set
hardware parameters: Operation not permitted
Sep  9 02:59:57 nexus pulseaudio[2966]: module.c: Failed to load  module
"module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_1412_1712_alsa_capture_0"): initialization failed.

[dennis@nexus ~]$ rpm -q pulseaudio
pulseaudio-0.9.7-0.11.svn20070907.fc8
Comment 1 Lennart Poettering 2007-09-12 12:59:14 EDT
Hmm, it seems you are experiencing some issues with the device permissions,
unrelated to PA itself.

Could you please check whether ACLs are properly set for the devices in /dev/snd?

Are you running the latest HAL? The utopia versions from rhughes have broken ACL
support.
Comment 2 Dennis Jacobfeuerborn 2007-09-12 13:32:32 EDT
I'm running whatever is currently in rawhide. The permissions look fine, I have
added package versions, permissions and the output of pulseaudio -vv below:

[dennis@nexus ~]$ rpm -q hal pulseaudio
hal-0.5.10-0.git20070831.fc8
pulseaudio-0.9.7-0.11.svn20070907.fc8

[root@nexus ~]# ls -l /dev/snd/
total 0
crw-rw----+ 1 root root 116, 12 2007-09-12 19:22 controlC0
crw-rw----+ 1 root root 116,  8 2007-09-12 19:22 controlC1
crw-rw----+ 1 root root 116,  9 2007-09-12 19:22 midiC0D0
crw-rw----+ 1 root root 116, 11 2007-09-12 19:22 pcmC0D0c
crw-rw----+ 1 root root 116, 10 2007-09-12 19:22 pcmC0D0p
crw-rw----+ 1 root root 116,  7 2007-09-12 19:22 pcmC1D0c
crw-rw----+ 1 root root 116,  6 2007-09-12 19:22 pcmC1D0p
crw-rw----+ 1 root root 116,  5 2007-09-12 19:22 pcmC1D1p
crw-rw----+ 1 root root 116,  4 2007-09-12 19:22 pcmC1D2c
crw-rw----+ 1 root root 116,  3 2007-09-12 19:22 seq
crw-rw----+ 1 root root 116,  2 2007-09-12 19:22 timer

[root@nexus ~]# getfacl /dev/snd/*
getfacl: Removing leading '/' from absolute path names
# file: dev/snd/controlC0
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/controlC1
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/midiC0D0
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D0c
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D0p
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D0c
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D0p
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D1p
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D2c
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/seq
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/timer
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:dennis:rw-
group::rw-
mask::rw-
other::---

[root@nexus ~]# pulseaudio -vv
W: main.c: This program is not intended to be run as root (unless --system is
specified).
E: pid.c: stale PID file, overwriting.
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_10de_3f0_alsa_capture_2
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_10de_3f0_alsa_playback_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:1
sink_name=alsa_output.pci_10de_3f0_alsa_playback_0'
I: module-alsa-sink.c: Successfully enabled mmap() mode.
W: alsa-util.c: Cannot find mixer control "Master".
W: alsa-util.c: Cannot find fallback mixer control "PCM".
I: sink.c: Created sink 0 "alsa_output.pci_10de_3f0_alsa_playback_0" with sample
spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.pci_10de_3f0_alsa_playback_0.monitor"
with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+10
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device=hw:1
sink_name=alsa_output.pci_10de_3f0_alsa_playback_0").
I: module-alsa-sink.c: Starting playback.
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:1
source_name=alsa_input.pci_10de_3f0_alsa_capture_0'
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_10de_3f0_alsa_capture_0" with
sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+11
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device=hw:1
source_name=alsa_input.pci_10de_3f0_alsa_capture_0").
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:0
sink_name=alsa_output.pci_1412_1712_alsa_playback_0'
E: module-alsa-sink.c: Failed to set hardware parameters: Operation not permitted
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_1412_1712_alsa_playback_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1412_1712_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:0
source_name=alsa_input.pci_1412_1712_alsa_capture_0'
E: module-alsa-source.c: Failed to set hardware parameters: Operation not permitted
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_1412_1712_alsa_capture_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1412_1712_alsa_capture_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1412_1712_alsa_midi_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_10de_3f0_alsa_control__1
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1412_1712_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_3f0_alsa_playback_0
becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_10de_3f0_alsa_capture_0
becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #9; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #10; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus,
path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Sink alsa_output.pci_10de_3f0_alsa_playback_0 idle
for too long, suspending ...
I: module-alsa-sink.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_input.pci_10de_3f0_alsa_capture_0 idle
for too long, suspending ...
I: module-alsa-source.c: Device suspended...

Comment 3 Lennart Poettering 2007-09-23 20:29:53 EDT
Is this a 24-bit-only sound card with an ICE chip? The version of PA currently
in Rawhide doesn't support sound cards without 16bit samples. I will upload a
version that is compatible with these soundcards tomorrow.
Comment 4 Lennart Poettering 2007-09-25 09:18:55 EDT
Assuming that that you soundcard is one of those 24bit-only cards, I will close
this bug now, since the PA upload I made yesterday (0.9.7-0.12.svn20070925)
should work fine with those cards.

If not, feel free to reopen this bug!
Comment 5 Dennis Jacobfeuerborn 2007-09-25 22:15:27 EDT
Things look better but playback still doesn't work on my primary card (the ICE
based one). Pulseaudio now starts and I can play files with Audacious using the
on-board soundchip fine but when I select the ICE based card I don't hear
anything nor does the volume-meter show any activity.

Starting pulseaudio with "pulseaudio --log-target=syslog -vv" results in the
following output in the terminal:
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL plughw:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL plughw:0

and the following output in the syslog:
Sep 26 04:06:50 nexus pulseaudio[25311]: main.c: Page size is 4096 bytes
Sep 26 04:06:50 nexus pulseaudio[25311]: main.c: Fresh high-resolution timers
available! Bon appetit!
Sep 26 04:06:50 nexus pulseaudio[25311]: module-hal-detect.c: Trying capability alsa
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-sink.c: Successfully
enabled mmap() mode.
Sep 26 04:06:50 nexus pulseaudio[25311]: alsa-util.c: Cannot find mixer control
"Master".
Sep 26 04:06:50 nexus pulseaudio[25311]: alsa-util.c: Cannot find fallback mixer
control "PCM".
Sep 26 04:06:50 nexus pulseaudio[25311]: sink.c: Created sink 0
"alsa_output.pci_10de_3f0_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"
Sep 26 04:06:50 nexus pulseaudio[25311]: source.c: Created source 0
"alsa_output.pci_10de_3f0_alsa_playback_0.monitor" with sample spec "s16le 2ch
44100Hz"
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-sink.c: Using 4 fragments
of size 4352 bytes.
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-sink.c: Starting playback.
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded "module-alsa-sink"
(index: #0; argument: "device=hw:1
sink_name=alsa_output.pci_10de_3f0_alsa_playback_0").
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-source.c: Successfully
enabled mmap() mode.
Sep 26 04:06:50 nexus pulseaudio[25311]: alsa-util.c: Using mixer control "Capture".
Sep 26 04:06:50 nexus pulseaudio[25311]: source.c: Created source 1
"alsa_input.pci_10de_3f0_alsa_capture_0" with sample spec "s16le 2ch 44100Hz"
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-source.c: Using 4 fragments
of size 4352 bytes.
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded "module-alsa-source"
(index: #1; argument: "device=hw:1
source_name=alsa_input.pci_10de_3f0_alsa_capture_0").
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-sink.c: Successfully
enabled mmap() mode.
Sep 26 04:06:50 nexus pulseaudio[25311]: alsa-util.c: Unable to attach to mixer
plughw:0: No such file or directory
Sep 26 04:06:50 nexus pulseaudio[25311]: sink.c: Created sink 1
"alsa_output.pci_1412_1712_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"
Sep 26 04:06:50 nexus pulseaudio[25311]: source.c: Created source 2
"alsa_output.pci_1412_1712_alsa_playback_0.monitor" with sample spec "s16le 2ch
44100Hz"
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-sink.c: Using 4 fragments
of size 4408 bytes.
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded "module-alsa-sink"
(index: #2; argument: "device=hw:0
sink_name=alsa_output.pci_1412_1712_alsa_playback_0").
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-sink.c: Starting playback.
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-source.c: Successfully
enabled mmap() mode.
Sep 26 04:06:50 nexus pulseaudio[25311]: alsa-util.c: Unable to attach to mixer
plughw:0: No such file or directory
Sep 26 04:06:50 nexus pulseaudio[25311]: source.c: Created source 3
"alsa_input.pci_1412_1712_alsa_capture_0" with sample spec "s16le 2ch 44100Hz"
Sep 26 04:06:50 nexus pulseaudio[25311]: module-alsa-source.c: Using 4 fragments
of size 4408 bytes.
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded "module-alsa-source"
(index: #3; argument: "device=hw:0
source_name=alsa_input.pci_1412_1712_alsa_capture_0").
Sep 26 04:06:50 nexus pulseaudio[25311]: module-hal-detect.c: Loaded 4 modules.
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded "module-hal-detect"
(index: #4; argument: "").
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded
"module-esound-protocol-unix" (index: #5; argument: "").
Sep 26 04:06:50 nexus pulseaudio[25311]: protocol-native.c: loading cookie from
disk.
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded
"module-native-protocol-unix" (index: #6; argument: "").
Sep 26 04:06:50 nexus pulseaudio[25311]: module-volume-restore.c: starting with
empty ruleset.
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded
"module-volume-restore" (index: #7; argument: "").
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded
"module-default-device-restore" (index: #8; argument: "").
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded
"module-rescue-streams" (index: #9; argument: "").
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded
"module-suspend-on-idle" (index: #10; argument: "").
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded "module-x11-publish"
(index: #11; argument: "").
Sep 26 04:06:50 nexus pulseaudio[25311]: module.c: Loaded "module-gconf" (index:
#12; argument: "").
Sep 26 04:06:50 nexus pulseaudio[25311]: main.c: Daemon startup complete.
Sep 26 04:06:51 nexus pulseaudio[25311]: module-suspend-on-idle.c: Sink
alsa_output.pci_10de_3f0_alsa_playback_0 idle for too long, suspending ...
Sep 26 04:06:51 nexus pulseaudio[25311]: module-alsa-sink.c: Device suspended...
Sep 26 04:06:51 nexus pulseaudio[25311]: module-suspend-on-idle.c: Source
alsa_input.pci_1412_1712_alsa_capture_0 idle for too long, suspending ...
Sep 26 04:06:51 nexus pulseaudio[25311]: module-alsa-source.c: Device suspended...
Sep 26 04:06:51 nexus pulseaudio[25311]: module-suspend-on-idle.c: Source
alsa_output.pci_1412_1712_alsa_playback_0.monitor idle for too long, suspending ...
Sep 26 04:06:51 nexus pulseaudio[25311]: module-suspend-on-idle.c: Source
alsa_input.pci_10de_3f0_alsa_capture_0 idle for too long, suspending ...
Sep 26 04:06:51 nexus pulseaudio[25311]: module-alsa-source.c: Device suspended...
Sep 26 04:06:51 nexus pulseaudio[25311]: module-suspend-on-idle.c: Source
alsa_output.pci_10de_3f0_alsa_playback_0.monitor idle for too long, suspending ...
Sep 26 04:06:51 nexus pulseaudio[25311]: module-suspend-on-idle.c: Sink
alsa_output.pci_1412_1712_alsa_playback_0 idle for too long, suspending ...
Sep 26 04:06:51 nexus pulseaudio[25311]: module-alsa-sink.c: Device suspended...
Comment 6 Lennart Poettering 2007-10-02 18:43:15 EDT
But does the playback position in your player move forward?
Comment 7 Lennart Poettering 2007-10-02 18:44:15 EDT
Could you please also provide me with the output that is spit out when you type
"list" on the "pacmd" prompt!

Thanks,
Comment 8 Dennis Jacobfeuerborn 2007-10-03 08:34:01 EDT
> But does the playback position in your player move forward?

Yes the playback position moves forward normally.

> Could you please also provide me with the output that is spit out when you type
> "list" on the "pacmd" prompt!

What I noticed in the output is that the volume meter is listed as "RUNNING"
with a source "alsa_output.pci_1412_1712_alsa_playback_0.monitor" yet in the
list of sources that particular one is shown as "SUSPENDED". Also the sink for
the ICE1712 card is shown as "SUSPENDED" while the other one is shown as
"RUNNING" which doesn't look right.
This is the output I get while playing a file:

Memory blocks currently allocated: 56, size: 91.6 KiB.
Memory blocks allocated during the whole lifetime: 22700, size: 30.0 MiB.
Memory blocks imported from other processes: 55, size: 83.0 KiB.
Memory blocks exported to other processes: 0, size: 0 B.
Total sample cache size: 0 B.
Default sample spec: s16le 2ch 44100Hz
Default sink name: alsa_output.pci_1412_1712_alsa_playback_0
Default source name: alsa_input.pci_10de_3f0_alsa_capture_0
Memory blocks of type POOL: 1 allocated/5214 accumulated.
Memory blocks of type POOL_EXTERNAL: 0 allocated/0 accumulated.
Memory blocks of type APPENDED: 0 allocated/0 accumulated.
Memory blocks of type USER: 0 allocated/0 accumulated.
Memory blocks of type FIXED: 0 allocated/9918 accumulated.
Memory blocks of type IMPORTED: 55 allocated/7568 accumulated.
14 module(s) loaded.
    index: 0
        name: <module-alsa-sink>
        argument: <device=hw:1 sink_name=alsa_output.pci_10de_3f0_alsa_playback_0>
        used: -1
        auto unload: no
    index: 1
        name: <module-alsa-source>
        argument: <device=hw:1 source_name=alsa_input.pci_10de_3f0_alsa_capture_0>
        used: -1
        auto unload: no
    index: 2
        name: <module-alsa-sink>
        argument: <device=hw:0 sink_name=alsa_output.pci_1412_1712_alsa_playback_0>
        used: -1
        auto unload: no
    index: 3
        name: <module-alsa-source>
        argument: <device=hw:0 source_name=alsa_input.pci_1412_1712_alsa_capture_0>
        used: -1
        auto unload: no
    index: 4
        name: <module-hal-detect>
        argument: <>
        used: -1
        auto unload: no
    index: 5
        name: <module-esound-protocol-unix>
        argument: <>
        used: -1
        auto unload: no
    index: 6
        name: <module-native-protocol-unix>
        argument: <>
        used: -1
        auto unload: no
    index: 7
        name: <module-volume-restore>
        argument: <>
        used: -1
        auto unload: no
    index: 8
        name: <module-default-device-restore>
        argument: <>
        used: -1
        auto unload: no
    index: 9
        name: <module-rescue-streams>
        argument: <>
        used: -1
        auto unload: no
    index: 10
        name: <module-suspend-on-idle>
        argument: <>
        used: -1
        auto unload: no
    index: 11
        name: <module-x11-publish>
        argument: <>
        used: -1
        auto unload: no
    index: 12
        name: <module-gconf>
        argument: <>
        used: -1
        auto unload: no
    index: 13
        name: <module-cli-protocol-unix>
        argument: <>
        used: -1
        auto unload: no
2 sink(s) available.
    index: 0
        name: <alsa_output.pci_10de_3f0_alsa_playback_0>
        driver: <modules/module-alsa-sink.c>
        flags: HW_VOLUME_CTRL LATENCY HARDWARE 
        state: RUNNING
        volume: <0: 100% 1: 100%>
        mute: <0>
        latency: <92290 usec>
        monitor source: <0>
        sample spec: <s16le 2ch 44100Hz>
        channel map: <front-left,front-right>
        used by: <1>
        linked by: <1>
        module: <0>
        description: <ALSA PCM on hw:1 (ALC883 Analog) via DMA>
  * index: 1
        name: <alsa_output.pci_1412_1712_alsa_playback_0>
        driver: <modules/module-alsa-sink.c>
        flags: HW_VOLUME_CTRL LATENCY HARDWARE 
        state: SUSPENDED
        volume: <0: 100% 1: 100%>
        mute: <0>
        latency: <0 usec>
        monitor source: <2>
        sample spec: <s16le 2ch 44100Hz>
        channel map: <front-left,front-right>
        used by: <0>
        linked by: <1>
        module: <2>
        description: <ALSA PCM on plughw:0 (ICE1712 multi) via DMA>
4 source(s) available.
    index: 0
        name: <alsa_output.pci_10de_3f0_alsa_playback_0.monitor>
        driver: <modules/module-alsa-sink.c>
        flags: 
        state: SUSPENDED
        volume: <0: 100% 1: 100%>
        mute: <0>
        latency: <0 usec>
        sample spec: <s16le 2ch 44100Hz>
        channel map: <front-left,front-right>
        used by: <0>
        linked by: <0>
        monitor_of: <0>
        module: <0>
        description: <Monitor Source of ALSA PCM on hw:1 (ALC883 Analog) via DMA>
  * index: 1
        name: <alsa_input.pci_10de_3f0_alsa_capture_0>
        driver: <modules/module-alsa-source.c>
        flags: HW_VOLUME_CTRL LATENCY HARDWARE 
        state: SUSPENDED
        volume: <0:  51% 1:  51%>
        mute: <0>
        latency: <0 usec>
        sample spec: <s16le 2ch 44100Hz>
        channel map: <front-left,front-right>
        used by: <0>
        linked by: <0>
        module: <1>
        description: <ALSA PCM on hw:1 (ALC883 Analog) via DMA>
    index: 2
        name: <alsa_output.pci_1412_1712_alsa_playback_0.monitor>
        driver: <modules/module-alsa-sink.c>
        flags: 
        state: RUNNING
        volume: <0: 100% 1: 100%>
        mute: <0>
        latency: <0 usec>
        sample spec: <s16le 2ch 44100Hz>
        channel map: <front-left,front-right>
        used by: <1>
        linked by: <1>
        monitor_of: <1>
        module: <2>
        description: <Monitor Source of ALSA PCM on plughw:0 (ICE1712 multi) via
DMA>
    index: 3
        name: <alsa_input.pci_1412_1712_alsa_capture_0>
        driver: <modules/module-alsa-source.c>
        flags: HW_VOLUME_CTRL LATENCY HARDWARE 
        state: SUSPENDED
        volume: <0: 100% 1: 100%>
        mute: <0>
        latency: <0 usec>
        sample spec: <s16le 2ch 44100Hz>
        channel map: <front-left,front-right>
        used by: <0>
        linked by: <0>
        module: <3>
        description: <ALSA PCM on plughw:0 (ICE1712 multi) via DMA>
4 client(s) logged in.
    index: 1
        name: <PulseAudio Volume Control>
        driver: <pulsecore/protocol-native.c>
        owner module: <6>
    index: 3
        name: <XMMS>
        driver: <pulsecore/protocol-native.c>
        owner module: <6>
    index: 4
        name: <PulseAudio Volume Meter>
        driver: <pulsecore/protocol-native.c>
        owner module: <6>
    index: 5
        name: <UNIX socket client>
        driver: <pulsecore/cli.c>
        owner module: <13>
1 sink input(s) available.
    index: 1
        name: <Kenji Kawai - Ghost In The Shell (OST) - Making Of Cyborg>
        driver: <pulsecore/protocol-native.c>
        flags: 
        state: RUNNING
        sink: <0> 'alsa_output.pci_10de_3f0_alsa_playback_0'
        volume: <0: 100% 1: 100%>
        mute: <0>
        latency: <475215 usec>
        sample spec: <s16le 2ch 44100Hz>
        channel map: <front-left,front-right>
        resample method: auto
        module: <6>
        client: <3> 'XMMS'
1 source outputs(s) available.
    index: 1
        name: 'PulseAudio Volume Meter'
        driver: <pulsecore/protocol-native.c>
        flags: 
        state: RUNNING
        source: <2> 'alsa_output.pci_1412_1712_alsa_playback_0.monitor'
        latency: <0 usec>
        sample spec: <float32le 2ch 44100Hz>
        channel map: <front-left,front-right>
        resample method: copy
        owner module: <6>
        client: <4> 'PulseAudio Volume Meter'
1 cache entries available.
    name: <pulse-hotplug>
        index: <0>
        sample spec: <n/a>
        channel map: <n/a>
        length: <0>
        duration: <0.0s>
        volume: <0: 100% 1: 100% 2: 100% 3: 100% 4: 100% 5: 100% 6: 100% 7: 100%>
        lazy: yes
        filename: /usr/share/sounds/startup3.wav
0 autoload entries available.
Comment 9 Lennart Poettering 2007-10-15 13:10:38 EDT
Hmm, that pacmd dump you postes shows that XMMS is connected to the non-24bit
card. How does it look like if you connect XMMS to the 24-bit sink? (I mean,
this is where your problam occurs, right, so the dump of the problematic setup
is a lot more valuable to me)
Comment 10 Dennis Jacobfeuerborn 2007-10-15 15:13:23 EDT
I thought that selecting the card as default in the "Output Devices" tab in the
volume control would choose that card but that doesn't seem the be the case. How
do I select the card? Starting the device chooser results in an avahi error
message and while the device chooser starts up find after starting the avahi
service it doesn't show any devices under "default sink" so I'm not sure how to
choose that card as a default.

By the way using the "Sample Cache" tab in the PA manager and selecting the
right playback device results in proper playback so the playback itself works.
Comment 11 Lennart Poettering 2007-10-17 17:44:00 EDT
padevchooser only shows network zeroconf devices.

PA remembers the device used for apps and restores them when they connect to PA
the next time. The "default" device you can choose by right clicking on a device
in pavucontrol just sets the default for previously unknown applications.

Please right click on a stream in pavucontrol to move it to another device.
Comment 12 Dennis Jacobfeuerborn 2007-10-18 09:06:24 EDT
That did the trick and now things run fine, thanks! Allowing to set the output
and volume for each application individually is a nice approach and offers some
interesting new possibilities. :)

I did discover a problem with the implementation though. When I killed
pulseaudio and started it again it didn't remember the output settings for the
applications so I had to manually set all of them to the correct device again.

I think there are several problems here:

1. Pulseaudio should store the settings for the default audio device and the
individual application settings directly when they are changed so that they are
retained even in the case of a system crash.

2. Right now I have to start each application in order to be able to change its
output settings. There should be a way to do this even if the app is not running
so that I don't have to go back and forth between application and pavucontrol in
order to change those settings. Fixing number 1 above should make most of the
pain of this go away but if you are buying a new soundcard you still have to go
through this tedious process.

3. There should be a way to quickly reset the output settings of all
applications to the default output device i.e. when I put a new card in my
machine I should be able to select it as the new default and then tell
Pulseaudio to change all application outputs to the new default. Otherwise you
end up with the same problem mentioned in point 2 above.

4. This is more of an upgrade issue and not really related to the normal
operation of Pulseaudio. When upgrading the system from a non-Pulseaudio based
to a Pulseaudio based version (e.g. FC7->F8) Pulseaudio should pick up the old
system settings as default i.e. in my case I should have selected the 24bit card
as default because that was the default before installing Pulseaudio. This is
probably something that could be done in Anaconda as the yum upgrade path is not
really supported anyway. This wouldn't really have helped in my case but I'm
following rawhide and rawhide eats babies which I recognize but I think it's a
relevant concern for people who upgrade their system from release to release.
Comment 13 Lennart Poettering 2008-03-28 15:50:29 EDT
PA nowadays save the volume and device for each stream. There was however an
issue that PA didn't create ~/.pulse and thus this didn't work properly. This
has been fixed a while back in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.