Bug 285601 - TB78433da9 yumRepo.py:360:check:RepoError: Cannot find a valid baseurl for repo: core
TB78433da9 yumRepo.py:360:check:RepoError: Cannot find a valid baseurl for re...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 00:27 EDT by Tim McConnell
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 10:52:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash log from Pirut (2.17 KB, application/octet-stream)
2007-09-11 00:27 EDT, Tim McConnell
no flags Details

  None (edit)
Description Tim McConnell 2007-09-11 00:27:42 EDT
Description of problem:
Pirut fatal exception error

Version-Release number of selected component (if applicable):


How reproducible:
Launch Pirut and receive fatal exception error notification 


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Traceback (most recent call last):
  File "/usr/sbin/pup", line 650, in <module>
    main()
  File "/usr/sbin/pup", line 643, in main
    pup = PackageUpdater(not options.autoapply, options.config)
  File "/usr/sbin/pup", line 88, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 124, in __init__
    self.reset()
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 223, in reset
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 517, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 377, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 211, in populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 80, in postreposetup_hook
    repomirrors[str(repo)] = FastestMirror(repo.urls).get_mirrorlist()
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 512, in <lambda>
    urls = property(fget=lambda self: self._geturls(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 509, in _geturls
    self._baseurlSetup()
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 492, in _baseurlSetup
    self.check()
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 360, in check
    'Cannot find a valid baseurl for repo: %s' % self.id
RepoError: Cannot find a valid baseurl for repo: core

Local variables in innermost frame:
self: core


Expected results:
to update core 7 

Additional info:
Yum fails also
Comment 1 Tim McConnell 2007-09-11 00:27:42 EDT
Created attachment 192301 [details]
crash log from Pirut
Comment 2 Jeremy Katz 2007-09-11 08:59:39 EDT
Does it work if you disable the fastest mirror plugin?
Comment 3 Tim McConnell 2007-09-11 17:58:47 EDT
(In reply to comment #2)
> Does it work if you disable the fastest mirror plugin?

[root@red1 yum.repos.d]# yum --noplugins update
Repository updates-debuginfo is listed more than once in the configuration
Repository updates-source is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Error: Cannot retrieve repository metadata (repomd.xml) for repository: %s.
Please verify its path and try again

Guess that is a no 
I have also opened a thread on fedora forums
http://forums.fedoraforum.org/showthread.php?p=863219#post863219. 
It will explain what else I have tried. 
Comment 4 Jeremy Katz 2007-09-12 10:52:07 EDT
Based on your comments there, it looks like you had a corrupted repository
config.  I've made the handling for that quite a bit nicer for Fedora 8 so that
it'll be easier for people to fix problems.

Note You need to log in before you can comment on or make changes to this bug.