Bug 285821 - RHEL-5-manual: virt-install manual should be more clean about SELinux and xen images locations
RHEL-5-manual: virt-install manual should be more clean about SELinux and xen...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.1
All Linux
high Severity high
: ---
: ---
Assigned To: Christopher Curran
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 08:28 EDT by Flavio Leitner
Modified: 2009-08-20 00:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 02:32:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Leitner 2007-09-11 08:28:57 EDT
Description of problem:

http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Virtualization-en-US/virt-install-wizard.html

There we have:
"The default SELinux policy permits xen disk images to reside in the /var/lib/xen.
If you have SELinux enabled and want to specify a custom path for the virtual
disk then you need to change SELinux policies accordingly"

we should be more emphatic about SELinux policies allow ONLY /var/lib/xen.
Comment 2 Don Domingo 2007-09-11 19:33:54 EDT
revised note as follows:

<quote>
SELinux policy only allows xen disk images to reside in
<filename>/var/lib/xen</filename>.
</quote>

will update online documentation soon. 
please advise if any further revisions are required.
Comment 6 Don Domingo 2008-01-31 20:12:48 EST
since this is a Virt-guide bug, reassigning to ccurran@redhat.com.

Chris, FYI for the book. you can close it after you've read it.

Note You need to log in before you can comment on or make changes to this bug.