This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 286151 - /usr/share/rhn/server/apacheRequest.py throws KeyError 'xmlrpc'
/usr/share/rhn/server/apacheRequest.py throws KeyError 'xmlrpc'
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Release (Show other bugs)
501
All Linux
high Severity high
: ---
: ---
Assigned To: Todd Sanders
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 11:16 EDT by Matt Domsch
Modified: 2008-10-29 10:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 10:22:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2007-09-11 11:16:35 EDT
Description of problem:


Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheRequest.py", line 106, in call_function
    func = self.method_ref(method)
  File "/usr/share/rhn/server/apacheRequest.py", line 401, in method_ref
    classes = self.servers[self.server]
KeyError: 'xmlrpc'

Exception reported from rhn.linuxdev.us.dell.com
Time: Tue Sep 11 09:03:19 2007
Exception type exceptions.KeyError
Exception while handling function queue.get
Request object information:
URI: /XMLRPC
Remote Host: 10.35.146.20
Server Name: rhn.linuxdev.us.dell.com:443
Headers passed in:
        Accept-Encoding: identity
        Content-Length: 2771
        Host: rhn.linuxdev.us.dell.com:443
        content-type: text/xml
        user-agent: rhn.rpclib.py/$Revision: 102540 $
        x-client-version: 1
        x-info: RPC Processor (C) Red Hat, Inc (version 102540)
        x-rhn-client-capability:
packages.verifyAll(1)=1,caneatCheese(1)=1,packages.extended_profile(1)=1,reboot.reboot(1)=1,packages.verify(1)=1,packages.runTransaction(1)=1,packages.rollBack(1)=1,packages.verifyAll(1)=1,caneatCheese(1)=1,packages.extended_profile(1)=1,reboot.reboot(1)=1,packages.verify(1)=1,packages.runTransaction(1)=1,packages.rollBack(1)=1
        x-rhn-transport-capability: follow-redirects=2
        x-transport-info: Extended Capabilities Transport (C) Red Hat, Inc
(version 102540)
        x-up2date-version: 0.4.13-1.el5
Extra information about this error:
Response sent back to the caller:
While running 'queue.get': caught
exceptions.KeyError : 'xmlrpc'



Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheRequest.py", line 106, in call_function
    func = self.method_ref(method)
  File "/usr/share/rhn/server/apacheRequest.py", line 401, in method_ref
    classes = self.servers[self.server]
KeyError: 'xmlrpc'



Version-Release number of selected component (if applicable):
$rpm -qf /usr/share/rhn/server/apacheRequest.py
rhns-server-5.0.1-10
(rpm -V yields only *.pyc files changed)

How reproducible:
always

Steps to Reproduce:
1. browse top of satellite server with web browser
2.
3.
  
Actual results:
HTTP 404 page

Expected results:
login page

Additional info:
rpm -qa | grep rhn

rhn-oracle-jdbc-1.0-11
mm-1.1.3-13.rhn.3.rhel4
rhn-modjk-ap13-1.2.6-3jpp
rhn-modperl-1.29-10.rhel4
quartz-1.5.1-1jpp_1rhn
rhns-schema-tools-3.5.0-278
rhn-dobby-4.9.0-10.rhel4
rhn-org-httpd-ssl-key-pair-rhn.linuxdev.us-1.0-1
rhns-config-files-common-5.0.1-10
rhns-applet-5.0.1-10
rhns-satellite-tools-5.0.1-10
rhn-java-config-sat-5.0.1-18
rhn-solaris-bootstrap-5.0.0-14
rhns-certs-tools-5.0.1-2.el4
rhn-pxt-5.0.1-11
rhn-cypress-5.0.1-11
jms-1.1-3jpp.1rhn
rhns-5.0.1-10
rhns-server-5.0.1-10
rhns-xml-export-libs-5.0.1-10
rhns-xmlrpc-5.0.1-10
rhns-config-files-5.0.1-10
rhns-package-push-server-5.0.1-10
rhns-xp-5.0.1-10
rhn-java-lib-sat-5.0.1-18
rhn-java-sat-5.0.1-18
rhn-i18n-release-notes-5.0.1-2
rhn-satellite-config-5.0.0-5
rhnpush-5.0.0-7
rhn-html-5.0.1-11
jabberd-2.0s10-3.29.rhn
rhn-base-5.0.1-11
rhn-grail-5.0.1-11
rhn-sniglets-5.0.1-11
rhn-satellite-admin-5.0.0-1
python-gzipstream-1.4.0-13.rhn.rhel4
rhn_solaris_bootstrap_4_1_0_16-1-0
rhn-oracle-jdbc-tomcat5-1.0-11
rhn-modssl-2.8.12-8.rhn.5.rhel4
rhn-modpython-2.7.11-1.rhel4
python-sgmlop-1.1.1-20040207.8.rhn.rhel4
jabberpy-0.5-0.8.rhn.rhel4
rhn-ssl-cert-check-1.4-6
quartz-oracle-1.5.1-1jpp_1rhn
rhn-swab-4.0.5-33.rhel4
rhnlib-2.1.1-3.el4
perl-Filesys-Statvfs-Df-0.72-4.rhn.rhel4
perl-GD2-2.17-1.rhn.rhel4
rhn-web-docs-4.1.0-1
tanukiwrapper-3.1.2-4jpp_1rhn
rhns-sql-5.0.1-10
rhns-app-5.0.1-10
rhns-config-files-tool-5.0.1-10
rhn_solaris_bootstrap_5_0_0_14-1-0
rhn-i18n-guides-5.0.0-11
rhn-satellite-schema-5.0.0-29
PyPAM-0.4.2-15.rhn
rhn-moon-5.0.1-11
rhn-apache-1.3.27-28.rhn.rhel4
Comment 1 Matt Domsch 2007-09-11 11:24:18 EDT
The rhel-instnum RPM is not installed in my system, and is not required by any
of the satellite RPMs, however it is used by rhns-xmlrpc-5.0.1-10.  Installing
that gets me a little further.

[Tue Sep 11 10:21:57 2007] [error] access to /index.pxt failed: File not found.

Comment 2 Matt Domsch 2007-09-11 11:27:23 EDT
Adding an old copy of index.pxt I had available, I can begin to log in, but
login fails with the following traceback:

[Tue Sep 11 10:25:16 2007] [error] returning 1 at
/usr/lib/perl5/site_perl/5.8.5/RHN/Access.pm line 64.
Exception reported from rhn.linuxdev.us.dell.com
Time: Tue Sep 11 10:25:43 2007
Exception type server.apacheRequest.UnknownXML
Exception while handling function queue.get
Request object information:
URI: /XMLRPC
Remote Host: 10.94.214.26
Server Name: rhn.linuxdev.us.dell.com:443
Headers passed in:
        Accept-Encoding: identity
        Content-Length: 2759
        Host: rhn.linuxdev.us.dell.com:443
        content-type: text/xml
        user-agent: rhn.rpclib.py/$Revision: 92982 $
        x-client-version: 1
        x-info: RPC Processor (C) Red Hat, Inc (version 93030)
        x-rhn-client-capability:
packages.verifyAll(1)=1,caneatCheese(1)=1,packages.extended_profile(1)=1,reboot.reboot(1)=1,packages.verify(1)=1,packages.runTransaction(1)=1,packages.rollBack(1)=1,packages.verifyAll(1)=1,caneatCheese(1)=1,packages.extended_profile(1)=1,reboot.reboot(1)=1,packages.verify(1)=1,packages.runTransaction(1)=1,packages.rollBack(1)=1
        x-rhn-transport-capability: follow-redirects=2
        x-transport-info: Extended Capabilities Transport (C) Red Hat, Inc
(version 92982)
        x-up2date-version: 4.5.5-7.el4
Extra information about this error:
Response sent back to the caller:
While running 'queue.get': caught
server.apacheRequest.UnknownXML : Invalid request received (Server xmlrpc is not
a valid XML-RPC receiver).



Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheRequest.py", line 106, in call_function
    func = self.method_ref(method)
  File "/usr/share/rhn/server/apacheRequest.py", line 407, in method_ref
    raise UnknownXML("Server %s is not a valid XML-RPC receiver" %
UnknownXML: Invalid request received (Server xmlrpc is not a valid XML-RPC
receiver).
Comment 3 Matt Domsch 2008-10-29 10:22:01 EDT
These have been open for years with no investigation or resolution.  Since then the code base has moved on significantly, such that many of these no longer would apply to the current spacewalk code.  I'm closing these requests in the hope they're no longer necessary, or if they are, they'll get discovered anew.

Note You need to log in before you can comment on or make changes to this bug.