Bug 286401 - Field checking in adding user not catching bad email format that causes service error
Field checking in adding user not catching bad email format that causes servi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sebastian Skracic
Stephen Herr
https://rhn.webqa.redhat.com/rhn/user...
:
: 223116 (view as bug list)
Depends On:
Blocks: 446437 447946
  Show dependency treegraph
 
Reported: 2007-09-11 13:21 EDT by wes hayutin
Modified: 2008-06-26 16:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 16:21:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2007-09-11 13:21:27 EDT
Description of problem:

Create a user in hosted w/ all the correct fields entered except in the email
field add something like..

shadow@..man.com

then click create.. and you get  a service error.
Special charaters appear to be allowed in the email form, however extra periods
cause a service error.
example..   wes@.redhat.com  causes service error.  
example..  wes@*redhat.com is allowed.. not sure if it should be.
Please field check the create user forms.

Also it appears that entering in a state in lowercase letters is accepted by
rhn.. but not accpeted at the /sso/process_login.html screen
example "nc" as opposed to "NC"

This should be consistent.   so sorry but there are two bugs here.
Comment 2 Amy Owens 2008-05-14 12:38:31 EDT
moving to sprint 8
Comment 3 Amy Owens 2008-05-22 11:49:45 EDT
OK I cloned this BZ for SSO--- the validation should be in user service but for
now RHN will do a simple email validation... 

Sebastian, just do minimal sanity checking
Comment 4 Sebastian Skracic 2008-05-27 11:54:48 EDT
The proper email validation against UserService should now be in place with
r118774.  Please note that wes@*redhat.com is still allowed (if unique), since
it passes the UserService validation.
Comment 5 Sebastian Skracic 2008-05-27 12:55:19 EDT
Small addendum to state code validation submitted in r118775.  For US and
Canada, users can enter either lower or upper case state codes.
Comment 7 Sebastian Skracic 2008-06-05 08:58:59 EDT
*** Bug 223116 has been marked as a duplicate of this bug. ***
Comment 8 Amy Owens 2008-06-05 09:29:01 EDT
*** Bug 223116 has been marked as a duplicate of this bug. ***
Comment 9 Amy Owens 2008-06-17 13:05:20 EDT
no longer throws stack trace--- says invalid email address with 
amy@.redhat.com-- in stage now

Note You need to log in before you can comment on or make changes to this bug.