This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 28646 - Fix warnings from Tru64 cc
Fix warnings from Tru64 cc
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
David Lawrence
:
: 32422 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-21 13:12 EST by Joe Orton
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-07 15:34:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix warnings. (569 bytes, patch)
2001-02-21 13:13 EST, Joe Orton
no flags Details | Diff
Build script of rpm 4.0.2 (107.69 KB, text/plain)
2001-04-17 14:34 EDT, Joe Orton
no flags Details
Make output for rpm 4.0.3-1.03 (169.17 KB, text/plain)
2001-12-10 10:22 EST, Joe Orton
no flags Details

  None (edit)
Description Joe Orton 2001-02-21 13:12:34 EST
This just fixes some warnings from rpmio_internal.h: trailing comma in
enum.
Comment 1 Joe Orton 2001-02-21 13:13:35 EST
Created attachment 10681 [details]
Fix warnings.
Comment 2 Jeff Johnson 2001-02-21 14:49:14 EST
There's gonna be beaucoup other cases throughout rpm code. Can you throw
rpm-4.0.2
underneath a Tru64 compiler and attach the many errors here? Thanks.
Comment 3 Jeff Johnson 2001-04-03 10:10:18 EDT
*** Bug 32422 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Johnson 2001-04-17 14:13:00 EDT
Still looking for Tru64 warnings when compiling rpm-4.0.3/4.1 ...
Comment 5 Joe Orton 2001-04-17 14:33:24 EDT
Sorry, I forgot about this.

Fixes still needed to build with rpm-4.0.2:
- take tools out of SUBDIRS (tools break under --disable-nls)
- add #define _GNU_SOURCE to misc/glob.h

build script coming up.
Comment 6 Joe Orton 2001-04-17 14:34:19 EDT
Created attachment 15544 [details]
Build script of rpm 4.0.2
Comment 7 Phil Copeland 2001-06-04 14:47:05 EDT
Is this a dead issue now?
If so, please close this record

Cheers
Comment 8 Jeff Johnson 2001-12-09 15:10:59 EST
Joe can you supply a new build of rpm-4.0.3 with Tru64 cc? I'll
then try to get rid of any remaining compiler cruft.
Comment 9 Joe Orton 2001-12-10 10:22:54 EST
Created attachment 40268 [details]
Make output for rpm 4.0.3-1.03
Comment 10 Joe Orton 2001-12-10 10:28:10 EST
I've attached the make output from rpm-4.0.3-1.03, patched to fix problems
with integrated DB3 etc.  Haven't got time to forward port the patches to
4.0.3-final at the moment, so I can't supply build output from that.
Comment 11 Paul Nasrat 2005-06-07 15:34:48 EDT
Old bug, if you still need Tru64 support please try and build latest RPM rediff,
and reopen.

Note You need to log in before you can comment on or make changes to this bug.