Bug 286731 - use url/method param for repository in addition to repo lines
use url/method param for repository in addition to repo lines
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 15:24 EDT by David Cantrell
Modified: 2013-01-09 20:41 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 16:44:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Cantrell 2007-09-11 15:24:37 EDT
When using a kickstart file to describe a pungi tree build, the repo lines
define the repositories that pungi should pull from.  The url or method
parameter should also be used since that's the base installation repository for
a regular kickstart install.

For example, I have these settings in my kickstart file:

url --url http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/
repo --name=skunkware
--baseurl=http://kevlar.boston.burdell.org/skunkware/fedora-devel-core/i386/
repo --name=skunkware-noarch
--baseurl=http://kevlar.boston.burdell.org/skunkware/fedora-devel-core/noarch/
repo --name=adobe --baseurl=http://linuxdownload.adobe.com/linux/i386/

But pungi needs a repo line for the repo specified in the url parameter.
Comment 1 Jesse Keating 2007-09-11 15:53:38 EDT
Not an unreasonable request.  I'll toy with adding support for this soon.
Comment 2 Jesse Keating 2007-09-12 16:44:39 EDT
Code has been committed to add this functionality.  It will only support url
method, not file or nfs or harddrive.  Note that you will not be able to use
--exclude or --include or --priority stuff.

Note You need to log in before you can comment on or make changes to this bug.