Bug 287211 - Unable to delete custom channel if associated with kickstart profile
Unable to delete custom channel if associated with kickstart profile
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Preethi Thomas
:
Depends On:
Blocks: 248627
  Show dependency treegraph
 
Reported: 2007-09-11 22:37 EDT by Mike McCune
Modified: 2008-04-02 20:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 20:19:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2007-09-11 22:37:33 EDT
If you try to delete a custom channel associated with a kickstart profile you
get a DB error:

/var/www/html/network/software/channels/manage/delete_confirm.pxt failed at Tue
Sep 11 22:16:54 2007: RHN::Exception: DBD::Oracle::st execute failed: ORA-02292:
integrity constraint (RHNSAT.RHN_KS_CC_CID_FK) violated - child record
found!ORA-06512: at "RHNSAT.DELETE_CHANNEL", line 15!ORA-06512: at line 2 (DBD
ERROR: OCIStmtExecute) [for Statement "BEGIN!  delete_channel(:p1);

Steps to reproduce:

1) login, create custom child channel from RHEL4 or RHEL5
2) create a Kickstart profile using base channel from step 1
3) Go to the "Operating System" page for the kickstart profile and check the box
next to the custom child channel.  Save the profile with the submit button.
4) Go back to the custom channel and attempt to delete it with the webui

We need to update the CASCADE delete for the rhnKickstartChildChannel table to
get cleaned up automatically.
Comment 1 Mike McCune 2007-09-11 22:39:49 EDT
Workaround:

* Go to all kickstart profiles that have the checkbox next to your custom child
channel selected.  Uncheck the box and save the Profile.
* Now you should be able to delete the Kickstart Profile.
Comment 2 Mike McCune 2007-09-11 22:40:11 EDT
arg, above workaround should say:

"... now you can delete the custom channel"
Comment 3 Jan Pazdziora 2007-10-10 03:11:57 EDT
Taking from Mike's plate.

Decreasing severity and priority since workaround exists.
Comment 4 Jan Pazdziora 2007-10-10 03:40:27 EDT
Fix committed to SVN, trunk, revision 132792.
Comment 6 Preethi Thomas 2007-10-26 09:17:49 EDT
verified
Comment 8 Brandon Perkins 2008-04-02 20:19:49 EDT
5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.