Bug 28758 - Upgrade fails on invalid filesystem on sdb1
Upgrade fails on invalid filesystem on sdb1
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-21 21:13 EST by Willem Riede
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-27 18:09:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Willem Riede 2001-02-21 21:13:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; U; Linux 2.2.15 i686)

I tried upgrading my RH 7.0. It's a SCSI only system (using the old aic7xxx
module thanks to rawhide). It has two SCSI disks (sda, sdb). Sdb1 is
currently not used (not refered to in /etc/fstab). It was supposed to be a
spare root partition for recovery purposes, but it's not usable at the
moment  - mount doesn't like it - but so what.
Anaconda should label partitions it can't recognize as 'unknown', not pop
up an error
message about sdb1 being invalid and not be able to continue. On one of the
consoles the error was reported as "VFS Can't find an ext2 filesystem on
sd(8,17)". Again, that observation is correct, but why get hung up on it?

Reproducible: Always
Steps to Reproduce:
1.have an invalid filesystem on a linux partition
2.run fisher anaconda install
3.click to acknowledge the error pop-up when it appears

Actual Results:  a blank screen in the graphical install instead of what
ever should have been the next step
Comment 1 Michael Fulbright 2001-02-27 18:09:28 EST
Please try the recent Wolverine beta release and report your results.
Comment 2 Willem Riede 2001-03-01 19:24:17 EST
I tried Wolverine as requested. I still get the popup "Error mounting ext2
filesystem on sdb1: Invalid argument" and the reported error message on console
4, but now after acknowledging the error, the install proceeds normally to the
Upgrade examine screen.

Thanks. Willem Riede.

Note You need to log in before you can comment on or make changes to this bug.